Follow us on:

Home

Inkscape tutorial: اصول ابتدایی

این آموزش گام به گام قرار است اصول و مفاهیم پایه‌ای کار با Inkscape را آموزش دهد. یک فایل عادی Inkscape را می‌توانید با کمک این برنامه ببینید، ویرایش کنید، کپی کرده و یا ذخیره کنید.

در اصول و مفاهیم پایه‌ای کار با Inkscape، مباحث پیمایش (اسکرول) صفحه، مدیریت فایل‌های Inkscape، اصول اولیه‌ی کار با اَشکال، تکنیک‌های انتخاب کردن، نحوه‌ی تغییر شکل دادن اشیاء با selector، گروه‌بندی، تنظیم رنگ و خط حاشیه، مرتب کردن اشیاء در صفحه و z-order بررسی خواهند شد.

پیمایش صفحه

راه‌های زیادی برای پیمایش (اسکرول) صفحه‌ وجود دارد. برای اسکرول به کمک صفحه کلید از Ctrl+کلید‌های جهت‌دار استفاده می‌شود. (همین الان، از این کلید‌ها برای اسکرول کردن صفحه به سمت پایین استفاده کنید.) همچنین می‌توانید صفحه را به کمک کلید وسط ماوس درگ کنید. یا، از نوار‌های پیمایش استفاده کنید (Ctrl+B این نوار‌ها را مخفی و مرئی می‌کند). برای پیمایش عمودی چرخک ماوس را به کار بگیرید با نگهداشتن کلید Shift در حین چرخاندن چرخک، پیمایش افقی حاصل می‌شود.

زوم کردن یا برگشت از زوم (zoom in or out)

آسانترین راه برای زوم کردن، استفاده از کلید های و + (یا = ) است. همچنین با استفاده از ctrl + کلیک وسط موس یا Ctrl + کلیک راست ماوس می‌توانید زوم کنید، Shift + کلیک وسط ماوس یا shift + کلیک راست موس برای برگشت از زوم به کار می‌آیند. عملیات مربوط به زوم و برگشت از زوم با نگه داشتن ctrl + چرخاندن چرخک ماوس نیز امکان پذیر است. با کلیک کردن در محدوده مربوط به زوم (در گوشه سمت راست پنجره سند)، مقدار دقیق زوم را به درصد بنویسید و کلید Enter را بزنید تا عملیات زوم به اندازه وارد شده انجام شود. همچنین ابزار Zoom در جعبه ابزار، سمت چپ به شما اجازه می‌دهد در محدوده‌ای که با ماوس حدودش را مشخص می‌کنید، زوم کنید.

نرم افزار Inkscape همچنین تاریخچه‌ای از مراحل زوم را در نشست کاری ذخیره می‌کند. کلید ` (کلیدی که علامت ~ دارد) را برای برگشتن به زوم قبلی و کلید Shift+` را برای رفتن به زوم بعدی بزنید.

ابزارهای Inkscape

جعبه ابزار عمودی سمت چپ، ابزار‌های طراحی و ویرایش Inkscape را نشان می‌دهد. در قسمت بالای پنجره زیر منو‌ی اصلی، نوار Commands با دکمه‌های فرامین عمومی وجود دارد. این دکمه‌ها برای ساختن یک فایل جدید، ذخیره کردن فایل جاری،چاپ کردن و مواردی از این دست به کار می‌روند. با نگه‌داشتن ماوس روی هر دکمه می‌توانید کارکرد آن را متوجه شوید. بعد از این نوار، نوار کنترل‌های مربوط به هر ابزار انتخاب شده قرار دارد. هر گاه ابزاری انتخاب شود، گزینه‌های این نوار برای تنظیم عملکرد آن ابزار تغییر می‌کنند (با انتخاب چند ابزار از نوار ابزار تغییراتی که در این نوار حاصل می‌شود را ببینید). نوار وضعیت در قسمت پایینی پنجره قرار دارد، این نوار پیام‌ها و نکات مفیدی در هنگام کار با نرم افزار نمایش خواهد داد.

بسیاری از اعمال را می‌توان با استفاده از میانبر‌های صفحه کلید انجام داد. برای دیدن مرجع کامل این میانبر‌ها از منوی Help زیر منوی Keys را انتخاب کنید.

ساختن و مدیریت اسناد

برای ساختن یک سند خالی، به File > New بروید یا کلید‌های Ctrl+N را بزنید. برای باز کردن یک سند موجود به فرمت SVG، از File > Open یا کلید‌های Ctrl+O استفاده کنید. برای ذخیره کردن سند نیز، مسیر File > را طی کنید یا کلید‌های Ctrl+S را بزنید. همچنین برای ذخیره کردن با یک اسم دیگر گزینه Save As را انتخاب کنید یا کلید‌های Shift+Ctrl+S را به خدمت بگیرید. (Inkscape ممکن است هنوز ناپایدار باشد، پس مرتبا فایلهایتان را ذخیره کنید!)

نرم افزار Inkscape از فرمت SVG (سرواژه ی عبارت Scalable Vector Graphics) برای ذخیره کردن فایل‌های خودش استفاده می‌کند. SVG یک استاندارد باز است که طیف گسترده‌ای از نرم افزار‌های گرافیکی آن را پشتیبانی می‌کنند. فایل‌های SVG بر پایه‌ی XML بنا شده‌اند و توسط هر ویرایشگر متنی یا ویرایشگر XML ای می‌توانند ویرایش شوند. Inkscape در کنار SVG چندین نوع قالب فایلی دیگر مثل (PNG و EPS) را می‌تواند وارد (import) و صادر (export) کند. ( import کردن یک فایل، یعنی اینکه آن فایل‌ را در سند ‌‌Inkscape به عنوان بخشی از فایلتان وارد کرده و از آن استفاده کنید. Export کردن یک فایل، یعنی فایلی که در Inkscape ساخته‌اید را می‌توانید به این فرمت‌ها درآورده و ذخیره کنید.)

نرم افزار Inkscape برای هر سند جدید، یک پنجره‌ی جدید باز می‌کند. با Alt+Tab یا سایر روش‌ها می‌توانید بین پنجره‌ها حرکت کنید، یا از میانبر Inkscape (کلید‌های Ctrl+Tab ) استفاده کنید که بین تمام پنجره‌های Inkscape که فایلی در آن باز شده باشد، سوییچ می‌کند. (همین الان یک سند جدید بسازید و برای تمرین بین آن و این سند سوییچ کنید.) نکته: Inkscape با این پنجره‌ها مثل تب‌های یک مرورگر وب رفتار می‌کند، یعنی میانبر Ctrl+Tab بین اسنادی که در یک پروسه اجرا شده باشند، سوییچ می‌کند. اگر چند فایل را از یک مدیر فایل اجرا کنید یا بیش از یک پروسه Inkscape اجرا کرده باشید، این میانبر برای تمام پنجره‌ها کار نخواهد کرد.

ساختن شکل‌ها

وقت کشیدن چند شکل نازنین است! روی ابزار مستطیل Rectangle در نوار ابزار کلیک کنید (یا کلید F4 را بزنید) و در یک سند جدید یا همینجا کلیک را نگه داشته و ماوس را بکشید و رها کنید (به این عمل درگ کردن می‌گویند)، در یک سند جدید یا همینجا مستطیل را بکشید:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

به مجموعه این ابزار‌ها، ابزار‌های ترسیم شکل (shape tools) می‌گویند. هر شکلی که ایجاد کنید یک یا چند اهرم چهارگوش دارد؛ سعی کنید آن‌ها را با ماوس بکشید تا اثر آن‌ها را بر شکل ببینید. یک راه دیگر برای تنظیم دقیق شکل وجود دارد. می‌توان پارامتر‌های نوار کنترل مربوط به ابزار را تنظیم کرد. این تغییرات بر روی شکلی که انتخاب شده باشد بلافاصله اعمال می‌شود. (معمولا اهرم‌های سفیدی روی شکلی که انتخاب شده باشد، دیده می‌شود) و اگر قبل از تغییر دادن پارامتر‌ها هیچ شکلی انتخاب نشده باشد، تغییرات بر اشکالی که بعدا ساخته شوند، اعمال خواهد شد.

برای خنثی کردن آخرین عمل انجام شده، کلید‌های Ctrl+Z را بزنید. (یا اگر دوباره نظرتان عوض شد، می‌توانید عمل خنثی شده را با زدن کلید‌های Shift+Ctrl+Z دوباره برگردانید.)

جابه‌جا کردن، مقیاس کردن، چرخاندن

پر‌استفاده‌ترین ابزار Inkscape، انتخابگر (Selector) است. روی بالاترین دکمه در نوار ابزار (شبیه شکل جهت (شبیه یک نشانگر ماوس مشکی!)) کلیک کنید، یا کلید F1 یا کلید Space را فشار دهید. حالا می‌توانید هر شئ‌ای را در صفحه انتخاب کنید. روی مستطیل زیر کلیک کنید.

An example image

حالا هشت اهرم شبیه فلش اطراف شکل می‌بینید. در این وضعیت می‌توانید:

حالا دوباره روی مستطیل کلیک کنید. (اگر شکل از حالت انتخاب خارج شده است، روی شکل دوبار کلیک کنید) حالا اهرم‌ها تغییر می‌کنند. می‌توانید:

در حالی که ابزار انتخابگر فعال است، در نوار کنترل‌ (بالای صفحه) مقادیر دقیق مختصات (X و Y) و اندازه (W و H) -همان طول و عرض- مربوط به شئ انتخاب شده را (به عدد!) وارد کنید. (توجه داشته‌ باشید که مقادیر H و W در واقع شکل را مقیاس می‌کند.)

تغییر شکل با کلید‌ها

یکی از ویژگی‌های Inkscape که آن را از بیشتر برنامه‌های ویرایشگر برداری جدا می‌کند، تاکید آن بر دسترسی از طریق صفحه کلید است. به سختی می‌توان فرمان یا عملیاتی را در Inkscape پیدا کرد که نتوان آن را از صفحه کلید انجام داد، و تغییر شکل اشیاء هم از این قاعده مستثنی نیست.

می‌توانید از کلید‌های جهت‌دار صفحه برای جابه‌جا کردن، کلید‌های < و > برای مقیاس کردن و کلید‌های [ و ] برای چرخاندن (دَوَران) اشیاء استفاده کنید. گام پیش فرض برای جابه‌جایی و مقیاس‌ کردن ۲ پیکسل است؛ با نگهداشتن کلید Shift می‌توانید این گام‌ را ۱۰ برابر کنید. Ctrl+> و Ctrl+< شئ را به ترتیب به ۲۰۰٪ و ۵۰٪ مقدار اصلی‌اش مقیاس می‌کنند. دوران‌های پیش فرض با گام‌های ۱۵ درجه‌ای اجرا می‌شوند؛ با نگهداشتن کلید Ctrl چرخش به گام‌های ۹۰ درجه‌ای افزایش خواهد یافت.

با این وجود، شاید مفید‌ترین مقدار گام برای تغییر شکل، گام‌های در اندازه پیکسل باشد، که با استفاده از نگهداشتن کلید Alt به همراه کلید‌های تغییر شکل اجرا می‌شوند. به عنوان مثال، Alt/+ کلیدهای جهت‌دار ناحیه انتخاب شده را به اندازه ۱ پیکسل در زوم فعلی جابه‌جا می‌کند (در عمل، این یک پیکسل را نباید با واحد اندازه گیری پیکسل که یک واحد اندازه گیری طول مستقل از زوم است، اشتباه گرفت). این به این معناست که اگر زوم کنید، نتیجه‌ی یک Alt+کلید جهت‌دار حرکت مطلق کوچکتری را نتیجه می‌دهد که هنوز به نظر یک پیکسل در صفحه می‌آید. بنابراین می‌توان اشیاء را با استفاده از زوم کردن یا برگشتن از زوم با دقت دلخواه در صفحه ساماندهی کرد.

به طور مشابه، Alt+> و Alt+< ناحیه‌ی انتخاب شده را به اندازه یک پیکسل در زوم فعلی مقیاس می‌کنند، و Alt+[ و Alt+] آن ناحیه را طوری می‌چرخانند که دورترین نقطه از مرکز شئ به اندازه یک پیکسل صفحه نمایش در زوم فعلی جابه‌جا شود.

نکته: کاربران گنو/لینوکس ممکن است از ترکیب Alt/+کلید‌های جهت‌دار و چند ترکیب دیگر از کلید‌ها نتیجه‌ای نگیرند، به خاطر اینکه مدیر پنجره‌شان احتمالاً رویداد آن کلید‌ها را قبل از رسیدن به برنامه Inkscape می‌گیرد. برای رفع این مشکل می‌بایست تنظیمات مدیر پنجره را به صورت مناسب تغییر داد.

انتخاب چندگانه

با نگه داشتن کلید Shift/ موقع کلیک کردن، می‌توانید هر تعداد شئ را به طور همزمان انتخاب کنید. یا می‌توانید اطراف اشیائی که می‌خواهید انتخاب شوند، ماوس را درگ کنید؛ به این روش انتخاب کردن، انتخاب روبانی می‌گویند. (ابزار انتخابگر با درگ کردن ماوس از یک فضای خالی یک روبان ایجاد می‌کند -منظور از این روبان در واقع همان مستطیل بی‌رنگ با خطوط مشکی‌ است که محدوده‌ی انتخاب شونده را مشخص می‌کند- ؛ البته اگر کلید Shift را قبل از فشار دادن کلید ماوس بزنید، Inkscape همیشه چنین روبانی می‌سازد). با انتخاب هر سه شکل زیر انتخاب کردن چند شئ را تمرین کنید:

An example image

حالا با استفاده از انتخاب روبانی (با درگ کردن یا Shift/+درگ کردن ) دو بیضی را انتخاب کنید طوریکه مستطیل در محدوده انتخاب شده نباشد:

An example image

هر شئ مجزای انتخاب شده، یک نشانه‌ی انتخاب نمایش می‌دهد. -به صورت پیش فرض، یک فریم نقطه چین مستطیل شکل است-. این نشانه‌ها دیدن اینکه چه چیزی انتخاب شده و چه چیزی انتخاب نشده است را آسان می‌کنند. به عنوان مثال، اگر هر دو بیضی و مستطیل را انتخاب کنید، بدون نشانه‌ها به سختی می‌توانید حدس بزنید که بیضی‌ها انتخاب شده‌اند یا نه.

اجرای Shift/+کلیک روی یک شئ انتخاب شده آن را از محدوده‌ی انتخاب خارج می‌کند. هر سه شئ بالا را انتخاب کنید، سپس با استفاده از Shift/+کلیک ، هر دو بیضی را از محدوده‌ی انتخاب خارج کنید تا فقط مستطیل در حالت انتخاب باقی بماند.

زدن کلید Esc همه‌ چیز را در لایه‌ی فعلی از محدوده‌ی انتخاب خارج می‌کند. (اگر لایه‌ای نساخته باشید، این مثل خارج کردن همه اشیاء سند از حالت انتخاب می‌شود)

گروه بندی

چند شئ می‌توانند ترکیب شده و یک گروه بسازند. یک گروه، موقع درگ کردن یا تغییر شکل دادن، مثل یک شئ منفرد رفتار می‌کند. در زیر، سه شئ سمت چپ مستقل هستند؛ سه شئ مشابه سمت راست گروه شده‌اند. سعی کنید گروه را به کمک ماوس درگ کنید.

An example image

برای ساختن یک گروه، یک یا چند شئ را انتخاب کرده و Ctrl+G را بزنید. برای خارج کردن یک یا چند گروه از حالت گروه‌بندی شده، آن‌ها را انتخاب کرده و Ctrl+U را بزنید. خود گروه‌ها، درست مثل بقیه اشیاء ممکن است دوباره و دوباره گروه‌بندی شوند و در تعداد این مراحل گروه‌بندی محدودیتی وجود ندارد؛ لازم به ذکر است که، Ctrl+U فقط در بالاترین سطح گروه انتخاب شده را از حالت گروه‌بندی خارج می‌کند؛ برای خارج کردن تمام اشیاء عضو یک گروه در گروه‌‌های عمیق از حالت گروه‌بندی باید زدن Ctrl+U چندین بار تکرار شود.

برای ویرایش یک شئ الزامی به خارج کردن آن از گروه نیست. فقط کافی است شئ را Ctrl/+کلیک کنید تا به تنهایی انتخاب شده و قابل ویرایش شود، یا چندین شئ (داخل یا بیرون از گروه) را با Ctrl+Shift/+کلیک کنید تا چند شئ صرفنظر از گروه‌بندی انتخاب و آماده ویرایش شود. سعی کنید اشیاء مجزای یک گروه را بدون از گروه خارج کردن، جابه‌جا کرده یا تغییر شکل دهید، سپس همه چیز را از حالت انتخاب شده خارج کرده، گروه را به طور طبیعی انتخاب کنید تا مطمئن شوید که گروه همچنان حالت گروه‌ بودنش را حفظ کرده است.

پُر کردن و حاشیه

بسیاری از توابع Inkscape در کادر‌های محاوره‌ای قرار داده شده‌اند. احتمالاً ساده‌ترین روش برای رنگ کردن یک شئ باز کردن کادر محاوره swatch از منوی View است (یا زدن کلید‌های Shift+Ctrl+W )، سپس مراحل کار چنین پیش می‌رود که شئ مورد نظر انتخاب می‌شود و با کلیک کردن روی یک رنگ برای رنگ کردن آن شئ، عملیات به پایان می‌رسد. (این روش عوض کردن رنگی است که شئ با آن پُر شده است).

از این قدرتمندتر، کادر محاوره Fill and Stroke از منوی Object است (یا کلید‌های Shift+Ctrl+F ). شئ زیر را انتخاب کنید و کادر محاوره Fill and Stroke را باز کنید.

An example image

خواهید دید که آن کادر سه تَب دارد:Stroke paint، Fill و Stroke style. تب fill به شما اجازه می‌دهد که ویژگی پُر‌شدگی (فضای داخل) شئ یا اشیاء انتخاب شده را ویرایش کنید. با استفاده از دکمه‌های پایین این تَب، می‌توانید نوع پُر شدن، شامل پُر نشدن (دکمه X دار)، رنگ یک دست (Flat color)، گرادیان‌های خطی (Linear gradient) یا گرادیان دایره‌ای (Radial gradient) را انتخاب کنید. برای شکل بالا، دکمه‌ی رنگ یک دست فعال خواهد بود. (گرادیان در واقع طیفی از رنگ‌هاست که از یک رنگ شروع شده و مرحله به مرحله به رنگ دیگر تبدیل می‌شود. می‌توان این طیف را با چندین رنگ نیز ایجاد کرد)

در قسمت پایین‌تر، مجموعه‌ای از رنگ گزین‌ها ( color pickers ) را در تب مخصوص خودشان می‌بینید: RGB, CMYK, HSL و Wheel. شاید مناسب‌ترین آن‌ها رنگ گزین Wheel باشد که شما می‌توانید با چرخاندن مثلث، تُن رنگ را از چرخ بگیرید، و سپس با انتخاب میزان سایه‌ی دلخواه از آن تُن، رنگ نهایی را انتخاب کنید. تمام رنگ گزین‌ها یک لغزنده برای تنظیم میزان آلفا (شفافیت) شئ یا اشیاء انتخاب شده دارند. (اگر شفافیت را صفر کنید، رنگ نامرئی به دست می‌آید)

هر زمان که یک شئ را انتخاب کنید، رنگ گزین برای نمایش رنگ پُر شده و حاشیه شئ به هنگام می‌شود (یعنی با انتخاب هر شئ رنگ و حاشیه‌ی مربوط به آن در این کادر محاوره‌ای نمایش داده می‌شود و می‌توان آن را تغییر داد) (با انتخاب چندین شئ، کادر محاوره رنگ متوسط‌شان را نشان می‌دهد). با این نمونه‌ها کار کنید یا نمونه‌های خودتان را بسازید.

An example image

با استفاده از تب Stroke paint، می‌توانید خط حاشیه‌ stroke (مرز) شئ را حذف کنید، یا رنگ دلخواه به آن نسبت داده یا آن را شفاف کنید:

An example image

آخرین تب، Stroke style، اجازه می‌دهد که عرض یا بقیه پارامتر‌های خط حاشیه را تنظیم کنید:

An example image

در آخر، به جای رنگ یک دست، می‌توانید از گرادیان‌ها برای پُر کردن و یا خط حاشیه اشیاء استفاده کنید:

An example image

وقتی از رنگ یک دست به گرادیان سوییچ می‌کنید، یک گرادیان جدید با استفاده از رنگ مذبور ساخته می‌شود که از مات به شفاف (از نامرئی به رنگ مورد نظر) می‌رود. به ابزار گرادیان سوییچ کنید ( Ctrl+F1 ) تا اهرم‌های گرادیان قابل جابه‌جا شدن شوند – کنترل‌های متصل شده به خطوط جهت و طول گرادیان را مشخص می‌کنند. وقتی یکی از اهرم‌های گرادیان انتخاب شده باشد (رنگش آبی پررنگ باشد)، کادر Fill and Stroke رنگ‌ آن اهرم را به جای رنگ تمام شئ، نشان داده و تنظیم می‌کند.

راه دیگری برای عوض کردن رنگ یک شئ وجود دارد، برای اینکار ابزار Dropper کلید ( F7 ) می‌تواند گزینه‌ی مناسبی باشد. برای استفاده از این ابزار، شکلی که می‌خواهید رنگ شود را انتخاب کنید، ابزار را فعال کنید و روی هر نقطه‌ای در صفحه که رنگ مورد نظرتان را دارد کلیک کنید تا شکل انتخاب شده به آن رنگ درآید (Shift/+کلیک رنگ حاشیه را تنظیم می‌کند).

تکثیر، هم‌ترازی، توزیع

یکی از پرکاربردترین اعمال، تکثیر یک شئ است ( Ctrl+D ). شئ تکثیر شده دقیقا بالای شکل اصلی قرار می‌گیرد و به حالت انتخاب شده در می‌آید، پس می توانید با درگ ماوس یا کلید‌های جهت‌دار آن را کنار بکشید. برای تمرین، سعی کنید از کپی‌های این مربع سیاه یک خط بسازید.

An example image

احتمالی که وجود دارد این است که کپی‌های مربع شما کم و بیش نامرتب باشند. این همان موقعیتی است که کادر Align مورد استفاده قرار می‌گیرد (Ctrl+Shift+A). برای مرتب کردن به کمک این کادر، تمام مربع‌ها را انتخاب کنید ( Shift/+کلیک برای درگ کردن یک روبان)، کادر را باز کنید و دکمه Center on horizontal axis را بزنید و پس از آن Make horizontal gaps between objects equal را بزنید (برای یافتن دکمه‌ی مناسب، ماوس را روی هر دکمه کمی نگهدارید و tooltip آن را بخوانید). اشیاء حالا مرتب و توزیع شده‌ هستند. در اینجا چند نمونه دیگر از مرتب سازی و توزیع آورده شده است:

An example image

Z-order

واژه‌ی z-order به سلسله مراتب پشت سر هم قرار گرفتن اشیاء در یک طراحی گفته می‌شود، مثلا اینکه کدام اشیاء بالا هستند و بقیه را می‌پوشانند و کدام اشیا زیر هستند و شاید بخشی از آن‌ها دیده می‌شود. در این رابطه دو دستور در منوی Object وجود دارد: Rise to Top (کلید Home ) و Lower to Bottom (کلید End ) که به ترتیب شئ انتخاب شده را به بالاترین سطح و پایین‌ترین سطح z-order در لایه‌ی فعلی می‌برند. دو دستور دیگر، Raise (کلید PgUp ) و Lower (کلید PgDn ) هستند که به اندازه یک سطح z-order شئ انتخاب شده را بالا یا پایین می‌آورند.

استفاده از این دستورات را با تغییر دادن z-order اشیاء زیر تمرین کنید، تا اولین بیضی از سمت چپ رو و اولین بیضی از سمت راست پشت بقیه بیضی‌ها قرار گیرد:

An example image

یک میانبر بسیار مفید کلید Tab است. اگر هیچ چیز انتخاب نشده باشد، کلید Tab، شئ‌ای که در پایین‌ترین سطح z-order باشد را انتخاب می‌کند؛ در غیر اینصورت، شئ‌ای که سطح z-order آن بالای شئ انتخاب شده باشد انتخاب می‌شود. Shift+Tab برعکس کار می‌کند، به این ترتیب که از بالاترین شئ شروع می‌کند و به سمت پایین حرکت می‌کند. از آنجا که اشیائی که می‌سازید به صورت پشته در سند ذخیره می‌شود، Shift+Tab زدن در حالتی که هیچ شئ‌ای انتخاب نشده باشد، آخرین شئ‌ای که اخیرا ساخته‌اید را انتخاب خواهد کرد. کار کردن با کلید‌های Tab و Shift+Tab را روی بیضی‌های بالا تمرین کنید.

انتخاب کردن شئ زیرین و درگ کردن آن

اگر شئ‌ای که نیاز دارید زیر شئ دیگری پنهان شده باشد، چه کار می‌کنید؟ اگر شئ بالایی (تا حدودی) شفاف باشد، ممکن است هنوز شئ زیری را ببینید، اما کلیک کردن روی آن باعث می‌شود شئ بالایی انتخاب شود و نه آنچه که شما می‌خواهید.

در این وضعیت Alt/+کلیک مفید واقع می‌شود. با چندبار زدن Alt/+کلیک می‌تواند اشیائی که در سطح z-order پایین‌تر هستند و در واقع پشت شی جلویی مخفی شده‌اند را انتخاب کنید. تکرار Alt/+کلیک در وضعیتی که آخرین شئ سطح z-order انتخاب شده باشد، باعث انتخاب شدن اولین شئ سطح z-order (در واقع جلوترین شئ) خواهد شد.

نکته: (اگر در لینوکس باشید، ممکن است متوجه شوید که Alt/+کلیک به درستی کار نمی‌کند. در عوض، ممکن است پنجره اصلی Inkscape را جابه‌جا کند. دلیلش این است که مدیر پنجره شما Alt/+کلیک را برای عملیات دیگری رزرو کرده است. برای رفع این مشکل، باید تنظیمات رفتار مدیر پنجره را پیدا کرده و یا آن را خاموش کنید یا آن را با کلید متا (همان کلیدی که عکس ویندوز روی آن درج شده است) عوض کنید تا Inkscape و سایر برنامه‌ها بتوانند آزادانه از Alt استفاده کنند.

تا اینجا همه چیز خوب است، اما وقتی یک شئ زیر سطحی را انتخاب می‌کنید، چه کاری می‌توانید با آن انجام‌دهید؟ شما می‌توانید از کلید‌ها برای تغییر شکل آن استفاده کنید و یا می‌توانید اهرم‌های ناحیه‌ی انتخاب شده را درگ کنید. البته، درگ کردن خود شئ، باعث ریست شدن سطح z-order شده و شئ موجود در بالاترین سطح را انتخاب و جابه‌جا خواهد کرد. (این چیزی است که کلیک و درگ برای آن ساخته شده است- مراحل کار به این شکل است که ابتدا بالاترین شئ زیر نشانگر ماوس را انتخاب شده، سپس ناحیه انتخاب شده درگ می‌شود). برای اینکه به Inkscape بگویید که شئ انتخاب شده را بدون انتخاب هیچ شئ دیگری درگ کند، از Alt/+درگ کردن استفاده کنید.

ترکیب‌های Alt/+کلیک و Alt/+درگ را روی دو شکل قهوه‌ای زیر مستطیل سبز شفاف تمرین کنید:

An example image

جمع بندی

این پایان آموزش گام به گام اصول مقدماتی Inkscape بود. مطالب زیادی در مورد Inkscape وجود دارد که بر پایه‌ی تکنیک‌هایی که در اینجا شرح داده شد، قابل اجرا خواهند بود. با گذراندن این بخش، شما قادر هستید که اشکال گرافیکی ساده ولی مفیدی بسازید. برای موارد پیچیده‌تر به بخش پیشرفته و سایر آموزش‌های گام به گام در Help > Tutorials رجوع کنید یا بخش بعدی این سری آموزشی را ببینید.