Este titorial mostra os fundamentos do uso de Inkscape. Este é un documento normal de Inkscape así que pode velo, modificalo, copiar algo del, ou gardalo.

O titorial Básico cobre a navegación polo lenzo, a xestión de documentos, os fundamentos das ferramentas de figuras, técnicas de selección, a transformación de obxectos co selector, a agrupación, a definición do recheo e do trazo, o aliñamento, e a orde-z. Para temas máis avanzados, consulte os outros titoriais no menú de Axuda.

Desprazar o lenzo

Hai varios xeitos de desprazar o lenzo do documento. Use as teclas Ctrl+frecha para desprazar usando o teclado. (Probe agora a desprazar o documento cara abaixo). Tamén pode arrastrar o lenzo co botón central do rato. Ou, pode usar as barras de desprazamento (prema Ctrl+B para mostralas ou ocultalas). A roda do rato tamén serve para desprazar verticalmente; prema Maiús para usar a roda para desprazar horizontalmente.

Achegar e alonxar (zoom)

A forma máis sinxela de usar o zoom é premer as teclas - e + (ou =). Tamén pode usar Ctrl+clic co botón central do rato ou Ctrl+clic co botón dereito do rato para achegar, Maiús+clic co botón central do rato ou Maiús+clic co botón dereito do rato para alonxar, ou mover a roda do rato mentres preme a tecla Ctrl. Ou pode premer no campo de entrada de ampliación (zoom) situado na esquina inferior dereita da xanela, introduza un valor de ampliación en %, e prema Intro. Tamén dispón da ferramenta Aumentar ou reducir o zoom (situada na barra de ferramentas da esquerda) que lle permitirá ampliar unha área seleccionándoa.

Inkscape tamén garda un historial dos niveis de ampliación (zoom) que se usaron durante a sesión de traballo. Prema a tecla ` para volver á ampliación anterior, ou Maiús+` para ir ao seguinte.

Ferramentas de Inkscape

A barra de ferramentas vertical da esquerda contén as ferramentas de debuxo e edición de Inkscape. Na parte superior da xanela, debaixo do menú, está a barra de ordes que contén botóns de accións xerais e a barra de controis de ferramentas que contén controis específicos de cada ferramenta. A barra de estado ao fondo da xanela mostrará consellos útiles e mensaxes mentres traballa.

Moitas operacións están dispoñibles a través de atallos de teclado. Abra Axuda > Referencia das teclas e do rato para ver a lista completa.

Creación e xestión de documentos

Para crear un novo documento baleiro, use Ficheiro > Novo ou prema Ctrl+N. Para abrir un documento SVG xa existente, use Ficheiro > Abrir (Ctrl+O). Para gardar, use Ficheiro > Gardar (Ctrl+S), ou Gardar como (Maiús+Ctrl+S) para gardalo cun novo nome. (Inkscape aínda pode ser inestable así que lembre gardar a miúdo!)

Inkscape usa o formato SVG (Scalable Vector Graphics) para os seus ficheiros. SVG é un estándar aberto que é compatible cun amplo número de programas de manipulación de imaxe. Os ficheiros SVG están baseados en XML e pódense modificar con calquera editor de texto ou de XML (ademais de con Inkscape, claro está). Ademais de SVG, Inkscape pode importar e exportar varios outros formatos (EPS, PNG...).

Inkscape abre unha xanela para cada documento. Pode moverse entre elas usando o xestor de xanelas (p.ex. usando Alt+Tab), ou pode usar o atallo de Inkscape, Ctrl+Tab, que se moverá en ciclo a través de todas as xanelas con documentos abertos. (Cree agora un novo documento e móvase a el e de volta a esta xanela para practicar). Nota: Inkscape trata a estas xanelas como se fosen lapelas dun navegador web, o que significa que o atallo de teclado Ctrl+Tab só funciona con documentos que se executan no mesmo proceso. Se abre varios ficheiros desde un navegador de ficheiros ou inicia máis dun proceso de Inkscape dende unha icona isto non funcionará.

Creación de figuras

É hora de crear algunhas figuras! Prema na ferramenta Rectángulo da barra de ferramentas (ou prema F4) e faga clic e arrastre, xa sexa nun documento novo ou neste mesmo:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

Estas ferramentas en conxunto coñécense como ferramentas de figura. Cada figura que cree mostra unha ou máis asas con forma de diamante; intente arrastralas para ver como responde a figura. O panel de controis dunha ferramenta de figura é outro xeito de modificar unha figura; estes controis aféctanlle á figura seleccionada (é dicir, a aquelas que mostran as asas) e definen as caracteristicas que se aplicarán ás figuras que se creen posteriormente.

Para desfacer a súa última acción, prema Ctrl+Z. (Ou, se cambia de idea despois, pode refacer a acción desfeita usando Maiús+Ctrl+Z.)

Mover, escalar, rotar

A ferramenta que máis se usa do Inkscape é o Selector. Prema no botón superior (o da frecha) da barra de ferramentas, ou prema F1 ou Espazo. Agora pode seleccionar calquera obxecto do lenzo. Prema no rectángulo de embaixo.

An example image

Verá que aparecen oito asas con forma de frecha arredor do obxecto. Agora pode:

Agora prema outra vez no rectángulo. As asas cambian. Agora pode:

Mentres estea no Selector, tamén pode usar os campos de entrada numéricos da barra de Controis (enriba do lenzo) para definir os valores exactos das coordenadas (X e Y) e o tamaño (L e H) da selección.

Transformación mediante o teclado

Unha das características de Inkscape que o diferencian da maioría dos outros editores vectoriais é a súa énfase na accesibilidade co teclado. É dificil atopar algunha orde ou acción que sexa imposible de facer co teclado, e transformar os obxectos non é unha excepción.

Pode usar o teclado para mover (teclas das frechas), escalar (teclas < e >), e rotar (teclas [ e ]) obxectos. Por defecto móvese e escálase 2 px; usando Maiús, poderá mover ou escalar dez veces iso. Usando Ctrl+> e Ctrl+< poderá escalar ao 200% ou 50% do orixinal, respectivamente. A rotación predefinida é de 15 graos; usando Ctrl, poderá rotar de 90 en 90 graos.

Aínda así quizais sexan máis útiles as transformacións a nivel de píxel, que se realizan usando Alt en conxunción cas teclas de transformación. Por exemplo Alt+frechas moverá a selección 1 píxel co nivel de zoom actual (é dicir 1 píxel da pantalla, que non se debe confundir ca unidade px unit que é unha unidade de lonxitude de SVG independente do zoom). Isto significa que se aumenta o zoom, a execución de Alt+frecha terá como resultado un movemento absoluto menor que aínda así aparecerá na pantalla como un movemento de un píxel. Deste xeito é posible situar obxectos cunha precisión arbitraria con só aumentar ou reducir o zoom tanto como for necesario.

De forma semellante, Alt+> e Alt+< escalan a selección de forma que o seu tamaño visible cambia un píxel da pantalla, e Alt+[ e Alt+] rotan a selección de forma que o punto máis distante do centro móvese un píxel da pantalla.

Nota: os usuarios de Linux pode que non obteñan os resultados desexados con Alt+frecha e algunhas outras combinacións de teclas se o seu xestor de xanelas se apropia deses eventos de teclas antes de que cheguen a Inkscape. Unha solución sería cambiar a configuración do xestor de xanelas para que non use ditas combinacións.

Seleccións múltiples

Pode seleccionar calquera número de obxectos de forma simultánea usando Maiús+clic (premendo en cada un deles). Ou, pode arrastrar arredor dos obxectos que precisa seleccionar; isto chámase selección elástica. (O selector crea unha banda elástica ao arrastrar desde un espazo baleiro; aínda así se preme Maiús antes de comezar a arrastrar, Inkscape sempre creará a banda elástica). Practique seleccionando as tres figuras de abaixo:

An example image

Agora use a selección elástica (arrastrando ou usando Maiús+arrastrar) para seleccionar as dúas elipses pero non o rectángulo:

An example image

Cada obxecto individual dunha selección mostra unha marca de selección — por defecto, un marco rectangular punteado. Estas marcas fan fácil ver o que está seleccionado e o que non. Por exemplo, se selecciona as dúas elipses e máis o rectángulo, sen as marcas custaríalle moito adiviñar se as elipses están seleccionadas ou non.

Con Maiús+clic sobre un obxecto seleccionado excluirá dito obxecto da selección. Seleccione os tres obxectos de enriba e use Maiús+clic para excluír as dúas elipses da selección deixando só o rectángulo seleccionado.

Se preme Esc deseleccionará todos os obxectos seleccionados. Ctrl+A selecciona todos os obxectos da capa actual (se non creou capas, é o mesmo que seleccionar todos os obxectos do documento).

Agrupar

Pódense xuntar varios obxectos nun grupo. Un grupo compórtase coma un único obxecto cando o arrastra ou o transforma. Embaixo, os tres obxectos da esquerda son independentes; os tres obxectos da dereita están agrupados. Intente arrastrar o grupo.

An example image

Para crear un grupo, seleccione un ou máis obxectos e prema Ctrl+G. Para desagrupar un ou máis grupos, seleccióneos e prema Ctrl+U. Os grupos tamén poden estar dentro de grupos, como calquera outro obxecto; eses grupos recursivos poden estar agrupados as veces que sexa. Aínda así, Ctrl+U só desagrupa o grupo de nivel superior dunha selección; terá que premer Ctrl+U varias veces se desexa desagrupar totalmente un grupo con moitos niveis de agrupación.

Aínda así, se desexa editar un obxecto que está dentro dun grupo non ten que desagrupar. Só ten que executar Ctrl+clic sobre o obxecto e este seleccionarase para editalo por separado, ou execute Maiús+Ctrl+clic sobre varios obxectos (dentro ou fóra de calquera grupo) para realizar unha selección múltiple sen ter en conta a agrupación. Intente mover ou transformar por separado as figuras do grupo (enriba á dereita) sen desagrupalo, despois deseleccione e seleccione o grupo de forma normal para comprobar que aínda está agrupado.

Recheo e trazo

Moitas das funcións de Inkscape están dispoñibles a través de caixas de diálogo. Probablemente a forma máis sinxela de pintar un obxecto con algunha cor é abrir a caixa de diálogo Paleta de mostras desde o menú Ver (ou premer Maiús+Ctrl+W), seleccionar un obxecto, e premer nunha cor para pintalo (cambia a súa cor de recheo).

Pero é máis potente a caixa de diálogo Recheo e trazo do menú Obxecto (ou prema Maiús+Ctrl+F). Seleccione a figura de embaixo e abra a caixa de diálogo de Recheo e trazo.

An example image

Verá que a caixa de diálogo ten tres lapelas: Recheo, Pintar o trazo, e Estilo do trazo. A lapela Recheo permítelle modificar o recheo (interior) dos obxectos seleccionados. Se usa os botóns que están xusto debaixo da lapela, poderá seleccionar tipos de recheo, incluindo non pintar (o botón do X), recheo de cor uniforme, así como degradados lineais ou radiais. Na figura de enriba marcouse o botón de recheo uniforme.

Máis abaixo pode ver un conxunto de selectores de cor, cada un na súa propia lapela: RGB, CMYK, HSL, e a Roda. Quizais o máis útil sexa o selector de Roda, no que pode rotar o triángulo para elixir un matiz na roda, e despois seleccionar unha sombra dese matiz dentro do triángulo. Todos os selectores de cor conteñen un control desprazable para definir o alfa (opacidade) dos obxectos seleccionados.

Cando selecciona un obxecto, o selector de cor actualízase para mostrar o seu recheo e trazo (cando hai varios obxectos seleccionados, a caixa de diálogo mostra a cor media). Xogue con estes exemplos ou cree o seu propio:

An example image

Se usa a lapela Pintar o trazo, poderá eliminar o trazo (contorno) do obxecto, ou asignarlle calquera cor ou transparencia:

An example image

A última lapela, Estilo do trazo, permítelle definir a largura e outros parámetros do trazo:

An example image

Por último, en troques de cor uniforme, pode usar degradados para os recheos e/ou os trazos:

An example image

Cando cambia dunha cor uniforme ao degradado, o novo degradado usa a cor uniforme anterior, indo de opaco a transparente. Cambie á ferramenta Degradado (Ctrl+F1) para arrastrar as asas de degradado — os controis conectados por liñas e que definen a dirección e a lonxitude do degradado. Cando se selecciona calquera das asas de degradado (resáltase en azul), o diálogo de Recheo e trazo define a cor desa asa en vez da cor de todo o obxecto seleccionado.

Outra forma útil para cambiar unha cor dun obxecto é usando a ferramenta Contagotas (F7). Simplemente prema en calquera parte do debuxo con esta ferramenta, e a cor seleccionada asignaráselle ao recheo do obxecto seleccionado (Maiús+clic asignaralle a cor ao trazo).

Duplicación, aliñamento, distribución

Unha das operacións máis comúns é duplicar un obxecto (Ctrl+D). O duplicado sitúase exactamente enriba do orixinal e aparece xa seleccionado, así que pode arrastralo co rato ou cas teclas das frechas. Para practicar, intente encher a liña con copias deste cadrado negro:

An example image

É posible que as copias do cadrado quedaran situadas de forma máis ou menos aleatoria. Aquí é onde resulta útil a caixa de diálogo de Aliñamento (Ctrl+Maiús+A). Seleccione todos os cadrados (use Maiús+clic ou a selección elástica), abra a caixa de diálogo e prema no botón «Centrar no eixe horizontal», e a continuación prema no botón «Igualar os ocos horizontais entre os obxectos» (lea as notificacións dos botóns). Agora os obxectos están ben aliñados e distribuídos de forma equidistante. Aquí ten algúns exemplos máis de aliñamento e distribución.

An example image

Orde-Z

O termo orde-Z refírese á orde de superposición dos obxectos dun debuxo, é dicir, indica que obxectos están enriba e ocultan a outros. As dúas ordes do menú Obxecto, «Elevar á cima» (a tecla Inicio) e «Baixar ao fondo» (a tecla Fin), moverán os obxectos seleccionados á cima de todo ou ao fondo de todo da orde-Z da capa actual. Outras dúas ordes, «Elevar» (Re Páx) e «Baixar» (Av Páx), subirán ou baixarán a selección só un nivel, é dicir, moverán a selección ata sobrepasar un obxecto non seleccionado na orde-Z (só ten en conta aos obxectos que se superpoñen á selección; se nada se superpón ca selección, «Elevar» e «Baixar» moverán a selección ata a cima ou ata o fondo).

Practique usando estas ordes para inverter a orde-Z dos obxectos de embaixo, de xeito que a elipse da esquerda de todo estea na cima e a que está máis á dereita estea no fondo:

An example image

Un atallo de selección moi útil é a tecla Tab. Se non hai nada seleccionado, selecciona o obxecto que está ao fondo de todo; en outro caso selecciona o obxecto que está sobre os obxectos seleccionados segundo a orde-Z. Maiús+Tab funciona ao revés, comeza no obxecto da cima e continúa cara abaixo. Xa que os obxectos que creou se engaden á cima da pila, se preme Maiús+Tab sen ter nada seleccionado seleccionarase o último obxecto que creou. Practique o uso das teclas Tab e Maiús+Tab na pila de elipses de enriba.

Seleccionar detrás e arrastrar a selección

Que se pode facer se o obxecto que necesita está oculto detrás de outro obxecto? É posible que aínda poida ver o obxecto do fondo se o que ten enriba é (parcialmente) transparente, pero se preme nel seleccionará o obxecto de enriba e non o que necesita.

Para isto temos Alt+clic. A primeira vez que se executa Alt+clic selecciónase o obxecto que está na cima igual que o fai o clic normal. Aínda así a seguinte execución de Alt+clic no mesmo lugar seleccionará o obxecto que está debaixo do que está na cima; na seguinte execución seleccionarase o obxecto que está debaixo do anterior, etc. Deste xeio varias execucións seguidas de Alt+clic percorrerán, de forma circular e de arriba cara abaixo, toda a pila de obxectos de orde-Z do punto onde premeu. Cando se chega ao obxecto do fondo, a seguinte execución de Alt+clic seleccionará outra vez o obxecto da cima.

[Se está en Linux, pode ser que Alt+clic non funcione como esperaba. En vez diso, pode que estea movendo toda a fiestra de Inkscape. Isto ocorre porque o xestor de fiestras reservou Alt+clic para unha acción diferente. A solución é ir á configuración de Comportamento de fiestras do xestor de fiestras, e desactivar o atallo de teclado, ou cambialo para que use a tecla Meta (tamén chamada tecla Windows), para que Inkscape e outros aplicativos poidan usar a tecla Alt sen problemas.]

Isto está ben, pero unha vez que ten seleccionado un obxecto que está detrás de outros, que pode facer con el? Pois pode usar as teclas para transformalo ou pode arrastrar as asas de selección. Aínda así arrastrar o propio obxecto volverá seleccionar o obxecto que está na cima (premer e arrastrar deseñouse para funcionar así — primeiro selecciona o obxecto (da cima) que está debaixo do cursor, e despois arrastra a selección). Para dicirlle a Inkscape que arrastre a selección actual sen seleccionar nada máis use Alt+arrastrar. Isto moverá a selección actual sen importar a onde arrastre o rato.

Practique Alt+clic e Alt+arrastrar cas dúas figuras castañas que están debaixo do rectángulo verde transparente:

An example image

Conclusión

Isto conclúe o titorial de Fundamentos. Hai moito máis que isto sobre Inkscape, pero cas técnicas que se describen aquí, xa será capaz de crear imaxes sinxelas e útiles. Para aprender cousas máis complicadas, consulte o titorial Avanzado e os outros titoriais dispoñibles en Axuda > Titoriais.