Az alábbi írás bemutatja az Inkscape használatának alapjait. Mivel ez az ismertető is egy szabályos Inkscape-dokumentum, így azon túl hogy nézegetheti, szerkesztheti és másolhat belőle, vagy el is mentheti.

A Bevezetés bemutatja a rajzvászon mozgatását, a dokumentumok kezelését, az alakzateszközök alapvető használatát, a kijelölési módszereket, a kijelölt objektumok átalakítását, a csoportosítást, a kitöltés és a körvonal beállításait, továbbá az igazítást és a z tengely fogalmát. A Segítség menüben található további ismertetők részletesebben tárgyalnak egyes témaköröket.

A rajzvászon mozgatása

A rajzvászon mozgatására többféle lehetőség is adódik. Görgethet billentyűzettel, a Ctrl+nyíl billentyűkombinációval. (Ki is próbálhatja, görgesse lejjebb ezt a dokumentumot.) A középső egérgomb vagy a gördítősáv (melyet a Ctrl+B lenyomásával megjeleníthet és elrejthet) is használható e célra. Az egérgörgő a vásznat függőlegesen, a Shift billentyű nyomva tartása mellett vízszintesen mozgatja.

Nagyítás és kicsinyítés

A nagyítást legegyszerűbben a - és a + (vagy =) billentyűkkel változtathatja. A Ctrl+középső gomb vagy a Ctrl+jobb gomb is nagyít, a Shift+középső gomb vagy a Shift+jobb gomb kicsinyít. Az egérgörgő a Ctrl nyomva tartásával szintén a nagyítást változtatja. A nagyítás beviteli mezőjébe (az ablak jobb alsó sarkában) beírható, majd Enterrel érvényesíthető a pontos nagyítási százalékérték. A Nagyító eszközzel (balra, az eszköztáron) a nagyítandó terület körberajzolható.

Az Inkscape emlékszik az adott munkamenetben végrehajtott nagyítási műveletekre. A ` billentyűvel visszatérhet az előző nagyításhoz, a Shift+` kombinációval pedig előre lépkedhet a nagyítási előzményekben.

Az Inkscape eszközei

A bal oldalon található függőleges eszköztár tartalmazza az Inkscape rajzoló és szerkesztő eszközeit. Az ablak felső részén, a menü alatt található az általános parancsgombokat tartalmazó Parancssáv és az eszközfüggő gombokat tartalmazó Eszközvezérlősáv. Az ablak alján látható Állapotsor hasznos tanácsokkal és üzenetekkel szolgál munka közben.

Sok művelet billentyűparancsokkal is végrehajtható. Ezek teljes listáját a Segítség > Billentyű- és egérkombinációk leírása menüpontban találja.

Dokumentumok létrehozása és kezelése

Egy új, üres dokumentumot a Fájl > Új paranccsal vagy a Ctrl+N kombinációval hozhat létre. Egy SVG-dokumentumot a Fájl > Megnyitás (Ctrl+O) paranccsal nyithat meg. Mentésre a Fájl > Mentés (Ctrl+S) vagy a Fájl > Mentés másként… (Shift+Ctrl+S) szolgál. Ez utóbbi akkor, ha új néven mentené a dokumentumot. (Programhibák még előfordulhatnak néha, így ne felejtsen el gyakran menteni.)

Az Inkscape saját formátuma az SVG (Scalable Vector Graphics). Ez egy – a grafikai szoftverek által széleskörűen támogatott – nyílt szabvány. Az SVG az XML leírónyelven alapul, így bármely szöveg- vagy XML-szerkesztővel (az Inkscape-en kívül, merthogy az is az) szerkeszthető. Az SVG mellett több más formátum (EPS, PNG) importjára és exportjára is lehetőséget ad a program.

Az Inkscape minden dokumentumot külön ablakban nyit meg. Ezen ablakok között az ablakkezelővel (pl. Alt+Tab) vagy az Inkscape nyitott dokumentumablakok között léptető gyorsbillentyűjével (Ctrl+Tab) válthat. (Gyakorlásként most hozzon létre egy új dokumentumot, és váltson az új és ezen dokumentum között.) Megjegyzés: Az Inkscape ezen ablakokat úgy kezeli, ahogyan a webböngészők a lapokat, azaz a Ctrl+Tab csak ugyanazon folyamat dokumentumaira működik. Ha Ön több fájlt nyit meg egy fájlkezelőből, vagy több Inkscape-folyamatot indít el egy ikonnal, akkor ez a módszer nem fog működni.

Alakzatok készítése

Itt az ideje rajzolni néhány alakzatot! Az eszköztáron kattintson a Téglalap eszközre (vagy nyomja le az F4 billentyűt), majd kattint-és-húz módszerrel rajzoljon egy új dokumentumba, vagy ide:

An example image

As you can see, default rectangles come up blue, with a black stroke (outline), and fully opaque. We'll see how to change that below. With other tools, you can also create ellipses, stars, and spirals:

An example image

Ezek az eszközök közös néven az alakzateszközök. Minden alakzathoz tartozik egy vagy több, négyszög vagy kör alakú fogantyú; próbálja mozgatni őket, és figyelje meg, hogy az alakzatok miként változnak. Alakzatok módosításának egy más módját nyújtja az Eszközvezérlősáv; az itt található vezérlők az éppen kijelölt alakzatra hatnak (azaz amelynek láthatók a fogantyúi), valamint alapértelmezett értékként az újonnan létrehozott alakzatokra.

A legutóbb végrehajtott műveletet a Ctrl+Z lenyomásával vonhatja vissza. (Vagy ha meggondolja magát, a Shift+Ctrl+Z kombinációval újra végrehajthatja a visszavont műveletet.)

Mozgatás, átméretezés, forgatás

A leggyakrabban használt Inkscape-eszköz a Kijelölő eszköz. Kattintson az eszköztáron a legfelső gombra (egy nyilat ábrázol), vagy nyomja meg az F1 vagy a Szóköz billentyűt. Ekkor ki tud jelölni bármilyen objektumot a vásznon. Kattintson az alábbi négyszögre.

An example image

Nyolc nyíl alakú fogantyút láthat az objektum körül. Ilyenkor lehetősége van:

Ha újra a négyszögre kattint, a fogantyúk megváltoznak. Így lehetősége van:

A Kijelölő eszköz Eszközvezérlősávján (a rajzvászon felett) levő beviteli mezőkben pontosan is megadhatja a kijelölt objektumok koordinátáit (X és Y) és méretét (Sz és M).

Átalakítás billentyűzettel

Az Inkscape többek közt a billentyűzettel való nagyfokú kezelhetőségében különbözik más vektorgrafikai programoktól. Alig van olyan parancs vagy művelet, amelyet billentyűzettel ne lehetne végrehajtani, és az objektumok átalakítása sem kivétel.

Billentyűzettel mozgathatja (kurzormozgató nyilak), méretezheti (< és >) és forgathatja ([ és ]) az objektumokat. Az alapértelmezett mozgatási vagy méretezési lépésköz 2 px; a Shift nyomva tartásával ennek tízszerese az elmozdítás. A Ctrl+> és a Ctrl+< hatása 200%-os, illetve 50%-os átméretezés. A forgatás alapértelmezetten 15°-onként, a Ctrl nyomva tartásával 90°-onként történik.

De talán a leghasznosabb a pixelmértékű átalakítás, mely a fenti billentyűk és az Alt együttes használatával valósítható meg. Például az Alt+nyíl a kijelölést az aktuális nagyítás szerinti 1 pixellel mozgatja el (azaz 1 képernyőpixellel, ne keverje össze a px mértékegységgel, amely az SVG hosszúsági mértékegysége, és független a nagyítástól.) Ezt úgy kell érteni, hogy ha növeli a nagyítást, akkor egy Alt+nyíl lenyomás kisebb abszolút elmozdulást eredményez, ám a képernyőn az továbbra is egy pixelnyi mozgásnak látszik. Ezáltal lehetőség van egy objektumot tetszőleges pontossággal elhelyezni, ehhez csak a nagyítást kell megfelelően növelni vagy csökkenteni.

Hasonlóan, az Alt+> és az Alt+< a kijelölés látható méretét egy képernyőpixellel változtatja meg. Az Alt+[ és az Alt+] forgatás a kijelölésnek a középponttól legtávolabb eső pontját mozgatja el egy képernyőpixellel.

Megjegyzés: Linux-felhasználók esetleg nem az elvárt működést tapasztalják az Alt+nyíl és még néhány billentyűkombináció esetében, ha az ablakkezelőjük elfogja az Inkscape elől ezeket a billentyűleütéseket. Az ablakkezelő beállításainak megfelelő megváltoztatása segíthet a probléma megoldásában.

Többszörös kijelölés

Egymás utáni Shift+kattintásokkal tetszőleges számú objektumot ki tud jelölni, vagy egérhúzással körbe is rajzolhatja a kijelölendő objektumokat; ez utóbbi a területkijelölés. (A Kijelölő eszköz megrajzolja a területet, amint egy üres területen kattintva húzni kezdi az egeret; viszont ha nyomva tartja a Shift billentyűt, mielőtt elkezdi a húzást, akkor a kezdőpont bárhol lehet, mindenképpen területkijelölés készül.) Próbaképpen jelölje ki mind a három alábbi alakzatot:

An example image

Jelölje ki területkijelöléssel (húzás vagy Shift+húzás) az alábbi két ellipszist úgy, hogy a négyszög ne kerüljön bele a kijelölésbe:

An example image

A kijelölésben minden különálló objektum körül egy kijelölésjelző látható – alapértelmezetten egy szaggatott vonalú, téglalap alakú keret. Ezen jelzők segítségével könnyen átlátható, hogy mi van és mi nincs éppen kijelölve. Például ha kijelöli a két ellipszist és a négyszöget is, akkor e jelzők nélkül nehéz lenne megállapítani, hogy az ellipszisek ki vannak-e jelölve vagy sem.

Egy objektumot Shift+kattintással vehet ki a kijelölésből. Jelölje ki mindhárom fenti objektumot, majd Shift+kattintással vegye ki a kijelölésből a két ellipszist, hogy csak a négyszög maradjon kijelölve.

Az Esc billentyű megszüntet minden kijelölést. A Ctrl+A kijelöli az összes objektumot az aktuális rétegen (ha nem hozott létre réteget, akkor ez megfelel a dokumentum összes objektumának).

Csoportosítás

Különböző objektumokat csoportba is foglalhat. Egy csoport mozgatáskor vagy átalakításkor úgy viselkedik, mint egy egyszerű objektum. Lent, a bal oldalon három különálló objektum látható; három ugyanilyen objektum a jobb oldalon csoportba van foglalva. Próbálja húzással elmozgatni a csoportot.

An example image

Egy vagy több kijelölt objektumot a Ctrl+G billentyűkkel foglalhat csoportba. A Ctrl+U kombinációval pedig felbonthatja a kijelölt csoportokat. Más objektumokhoz hasonlóan a csoportok maguk is csoportba foglalhatók; ilyen rekurzív csoportok tetszőleges mélységben készíthetők. Viszont a Ctrl+U csak a kijelölt csoport legfelső szintjét szünteti meg; így ha egy ilyen többszörös csoportot teljesen fel akar bontani, akkor ismételten használnia kell a Ctrl+U billentyűket, a csoport mélysége szerint.

De egy csoportban levő objektum szerkesztéséhez nem is kell felbontania a csoportot. Csak válassza ki Ctrl+kattintással az objektumot, és már szerkesztheti is, a csoporttól függetlenül. Ctrl+Shift+kattintásokkal egyidejűleg jelölhet ki különféle objektumokat (bármely csoportban vagy azon kívül is). Próbálja mozgatni vagy átalakítani valamelyik alakzatot a fenti csoportban (a jobb oldalon) anélkül, hogy a csoportot felbontaná, majd szüntesse meg a kijelölést, ezután újra jelölje ki a csoportot. Így láthatja, hogy az objektumok továbbra is csoportban vannak.

Kitöltés és körvonal

Számos művelet párbeszédablakok segítségével végezhető. Egy objektum kifestésének talán a legegyszerűbb módja, ha a Nézet menüből (vagy a Shift+Ctrl+W billentyűkkel) megnyitja a Színminták párbeszédablakot, kijelöl egy objektumot, majd választ egy mintát a kifestéshez (a kitöltés színének megváltoztatásához).

Még hasznosabb az Objektum menüből (vagy a Shift+Ctrl+F billentyűkkel) nyitható Kitöltés és körvonal párbeszédablak. Jelölje ki az alábbi alakzatot, és nyissa meg a Kitöltés és körvonal ablakát.

An example image

A párbeszédablakon három lapot láthat: Kitöltés, Körvonalrajzolat és Körvonalstílus. A Kitöltés lapon a kijelölt objektumok (belső) kitöltése állítható be. A fülek alatti gombokkal módosítható a kitöltés típusa: nincs kitöltés (az X gomb), egyenletes szín, lineáris vagy sugárirányú színátmenet. A fenti alakzat kijelölésekor az egyenletes szín aktiválódik.

A gombok alatt, egy-egy külön lapon találhatók a színválasztók: RGB, CMYK, HSL és Kerék. Valószínűleg a Kerék a legkényelmesebben használható színválasztó, ahol a háromszög forgatásával a kerékről kiválasztható egy szín, majd a háromszögben megadható a szín árnyalata. Mindegyik színválasztóhoz tartozik egy, a kijelölt objektumok alfaértékét (átlátszóságát) szabályozó csúszka.

Ha kijelöl egy objektumot, a színválasztó értékei az aktuális objektum színének megfelelően változnak (többszörös kijelölés esetén a színek átlagának megfelelően). Próbálgassa az alábbi alakzatokkal:

An example image

A Körvonalrajzolat lapon eltávolíthatja egy objektum körvonalát, vagy beállíthatja a körvonal színét és átlátszóságát:

An example image

A Körvonalstílus lapon tudja beállítani a körvonal szélességét és egyéb tulajdonságait:

An example image

Egyenletes szín helyett színátmenet is választható mind a kitöltéshez, mind a körvonalhoz:

An example image

Ha egyszínű kitöltésről színátmenetre vált, a kezdeti színátmenet az eredeti színen alapul, annak teljesen átlátszatlanból teljesen átlátszóba való átmenete lesz. Váltson a Színátmenet eszközre (Ctrl+F1), és a színátmenet fogantyúival alakíthatja a színátmenetet – a vezérlőket vonalak kötik össze, melyek meghatározzák a színátmenet irányát és hosszát. Ha bármelyik színátmenet-fogantyút kijelöli (kék szín jelzi), a Kitöltés és körvonal párbeszédablakban az ehhez a fogantyúhoz tartozó színt lehet beállítani, nem pedig az egész kijelölt objektumét.

A Színpipetta eszközzel (F7) is kényelmesen módosítható az objektumok színe. Csak kattintson az eszközzel bárhová, és a kijelölt objektum kitöltése (Shift+kattintás esetén a körvonal színe) a felszedett szín lesz.

Kettőzés, igazítás és elrendezés

Az egyik leggyakoribb művelet egy objektum megkettőzése (Ctrl+D). A másodpéldány pontosan az eredeti felett jön létre, majd egérrel vagy billentyűzettel áthelyezhető máshová. Gyakorlásképpen próbálja meg kitölteni a sort a fekete négyszög másolataival:

An example image

Előfordulhat, hogy a másolatok többé-kevésbé szabálytalanul helyezkednek el. Ezen segíthet az Igazítás és elrendezés párbeszédablak (Ctrl+Shift+A). Jelölje ki az összes négyszöget (Shift+kattintás vagy rajzolja körbe őket), nyissa meg a párbeszédablakot, válassza a „Középre igazítás a vízszintes tengelyhez” gombot, aztán „Az objektumok közti vízszintes helyek azonossá tétele” gombot (figyelje a gombok gyorstippjeit). Az objektumok így most egy sorban, egymástól egyenlő távolságra vannak. Íme néhány példa az igazítás és elrendezés egyéb módozataira:

An example image

Z tengely

A z tengely kifejezés a rajzon egymásra helyezett objektumok sorrendjére utal, vagyis hogy melyik objektum van felül, és takarja le a többit. Az Objektum menü két parancsa, a Felülre helyezés (a Home billentyű) és az Alulra helyezés (az End billentyű) a kijelölt objektumokat az aktuális réteg z tengelyén legfelülre vagy legalulra mozgatja. További két parancs, a Feljebb helyezés (PgUp) és a Lejjebb helyezés (PgDn) csak egy lépéssel mozgatja fel vagy le az objektumot, vagyis egy nem kijelölt objektumon túlra mozgatja a z tengelyen (csak azon objektumokon túl, melyek fedésben vannak a kijelölttel; ha nincs ilyen objektum, akkor rendre legfelülre vagy legalulra).

Gyakorlásképpen próbálja ezekkel a parancsokkal megfordítani az alábbi objektumok sorrendjét a z tengelyen úgy, hogy a bal oldali ellipszis legyen a legfelső, a jobbra levő pedig a legalsó:

An example image

Nagyon jól használható kijelölésre a Tab billentyű is. Ha semmi nincs kijelölve, akkor a legalsó objektumot jelöli ki; egyébként pedig a z tengelyen a kijelölt objektumok felett levőt. A Shift+Tab fordítva működik: a legfelső objektumtól indul, és lefelé halad. Mivel egy újonnan létrehozott objektum mindig legfelülre kerül, így ha olyankor nyomja meg a Shift+Tab kombinációt, amikor semmi sincs kijelölve, akkor ezzel a legutóbb létrehozott objektumot jelölheti ki. Próbálgassa a Tab és a Shift+Tab billentyűket a fenti ellipszisekkel.

Takart objektum kijelölése és kijelölt objektum húzása

Előfordulhat, hogy éppen egy másik takarásában levő objektummal szeretne dolgozni. Az alsó objektum még látható is lehet, ha a felette levő (részlegesen) átlátszó, de rákattintva csak a felső objektumot tudja kijelölni, az alatta levőt nem.

Ekkor használható az Alt+kattintás. Az első Alt+kattintás a felső objektumot jelöli ki, ahogy a rendes kattintás is. De a következő Alt+kattintás ugyanott már az alatta levőt, a következő az az alattit és így tovább. Tehát egymás utáni Alt+kattintásokkal egy adott helyen rendre kijelölhetők az ott a z tengely vonatkozásában egymáson elhelyezkedő objektumok. A legalsó objektumot elérve a következő Alt+kattintás újra a legfelső objektumot jelöli ki.

[Linuxon az Alt+kattintás esetleg nem a leírtaknak megfelelően működik, hanem az egész Inkscape-ablakot mozgatja. Ez akkor fordulhat elő, ha az ablakkezelőben az Alt+kattintáshoz valamilyen művelet van rendelve. Keresse meg az ablakkezelő beállításaiban az ablakműveletekre vonatkozó részt, és vagy kapcsolja ki a módosítóbillentyűt, vagy állítsa át a Meta (Windows) billentyűre, így az Inkscape és más alkalmazások is szabadon használhatják az Alt billentyűt.]

Mindez szép és jó, de mit lehet kezdeni egy másik objektum alatt elhelyezkedő, kijelölt objektummal? Billentyűzettel alakítható, és egérrel a kijelölő fogantyúi is mozgathatók. Viszont ha megpróbálja az objektumot magát egérrel arrébb húzni, akkor a kijelölés megszűnik, és a legfelső objektum válik kijelöltté (ahogy a kattintás-és-húzásnak működni is kell – kijelöli a kurzor alatti (legfelső) objektumot, és mozgatja a kijelölést). Ha egy jelenleg éppen kijelölt objektumot úgy szeretne húzni, hogy a kijelölés ne változzon meg a kattintás pillanatában, akkor az Alt+húzás a megfelelő módszer. Ez mindig az aktuális kijelölést mozgatja, attól függetlenül, hogy az egérrel hová kattintva kezdi a húzást.

Próbálja ki az Alt+kattintást és az Alt+húzást az átlátszó, zöld négyszög alatti barna alakzatokkal:

An example image

Zárszó

Ezzel véget is ért a Bevezetés. Az Inkscape a fentieknél jóval több lehetőséget nyújt, ám a bemutatott módszerek segítségével Ön már képes egyszerű, de használható grafikákat készíteni. Néhány témakörről részletesebben olvashat a Segítség > Ismertetők menüben található többi leírásban, például a Haladó címűben.