這篇教學將說明各種技巧和秘訣,使用者會學到透過使用 Inkscape 和一些「隱藏」功能來幫助你快速完成任務。

鋪排仿製的放射狀分佈

使用者很容易就懂得如何使用一般格線和圖樣的鋪排仿製對話窗。但是如果你需要放射狀分佈,物件群可共用同一個旋轉中心嗎?這是做得到的!

如果你的放射狀圖案只需要 3、4、6、8 或 12 個元件,那麼你可以試試 P3、P31M、P3M1、P4、P4M、P6 或 P6M 對稱。這些對製作雪花或類似的東西很有用。不過有一個更普遍的方法,如下。

選擇 P1 對稱 (簡單平移),然後切換到位移分頁並設定每行/位移 Y每列/位移 X 皆為 -100% 以補償剛剛的平移。這時全部的仿製物件會完全重疊在原始物件的上面。繼續切換到旋轉分頁並設定每列旋轉一些角度,然後以單行多列建立圖案。舉例來說,下面的圖案是用 30 列且每一列旋轉 6 度製作出來的:

An example image

要用這個方法製作一個時鐘刻度盤,只需要用一個白色圓形切掉或覆蓋中央的部份 (要在仿製物件上進行布林運算前先將物件取消連結)。

藉由同時使用行與列可製作更多有趣的效果。下面的圖案是用 10 列和 8 行,且每行旋轉 2 度而每列旋轉 18 度。這裡每個直線群組代表一「列」,所以群組彼此之間都相距 18 度;每列裡面的單獨直線則相隔 2 度:

An example image

在上面的例子裡,直線繞著自己的中心旋轉。但如果你想要的旋轉中心在形狀的外面怎麼辦?只要建立一個隱形 (無填色、無邊框) 的矩形,使矩形覆蓋你的形狀並讓其中心對準你要的點上,把形狀和矩形群組在一起,然後在群組上使用鋪排仿製。這就是利用隨機性的縮放、旋轉和透明來製作「爆炸」或「恆星爆裂」效果的方法。

An example image

如何將影像切片 (多個矩形輸出範圍)?

建立一個新圖層,在這圖層裡建立幾個隱形矩形,讓這些矩形分成幾個部份覆蓋你的影像。確認你的文件是使用 px 單位 (預設),開啟格線顯示並把矩形都貼齊格線,使每個矩形長度都是整數 px 單位。每個矩形都給予一個有意義的識別名稱 (ID),並且將每個矩形匯出成自己個別的檔案 (檔案 > 匯出點陣圖 (Shift+Ctrl+E))。而這些矩形會記住匯出的檔名。在那之後,就可以很容易的再次匯出一些檔案:切換到匯出圖層,使用 Tab 鍵來選擇你要匯出的區域 (或依照 ID 來尋找),然後點擊對話窗裡的匯出按鈕。或者,你可以寫一個 shell 腳本或批次命令檔來匯出所有區域,例如下面的指令:

inkscape -i 區域-id -t 檔名.svg

給每個匯出的區域。參數 -t 會告訴程式使用已記住的檔名提示,不然你可以用參數 -e 提供匯出的檔名。或者,你可以使用 svgslice 工具來自動從 Inkscape SVG 中匯出,使用切片圖層或參考線其中一種。

非線性漸層

SVG 版本 1.1 不支援非線性漸層 (即顏色之間有非線性轉變)。不過,你可以用多停止點漸層模擬類似的效果。

星形帶有簡單的兩點漸層。開啟漸層編輯器 (例如用漸層工具在任何漸層控制點上點擊兩下)。在中間位置加入新的漸層停止點;並稍微拖動它。然後在中間停止點的前後加入更多的停止點並且也拖動這些停止點,以便讓漸層呈現平滑狀態。你加入的這些停止點會讓生成的漸層更平滑。這裡有一開始帶有兩個停止點的黑白漸層:

An example image

而這邊有各種樣式的「非線性」多停止點漸層 (用漸層工具查看這些圖形):

An example image

離心放射狀漸層

放射狀漸層不一定要對稱。用漸層工具,按著 Shift 拖曳橢圓形漸層中央的控制點。這會使漸層中呈現 x 形狀之作用中的控制點從中心往外移動。當不需要時,你可以拖曳控制點往中心移回原本的位置。

An example image

對齊頁面中心

想要對齊頁面中心或邊緣,可選取物件或群組然後在對齊和分佈對話窗 (Ctrl+Shift+A) 裡從相對於: 清單中選擇頁面

清理文件

許多沒用到的漸層、圖樣和標記 (更準確地說是你手動編輯的那些) 保存在對應的參數面板中並可重複使用於新物件上。但是如果你想要將你的文件最佳化,請使用檔案選單裡的清空 Defs 指令。它會移除文件中沒有用到的漸層、圖樣或標記,使檔案體積更小。

隱藏特性和 XML 編輯器

XML 編輯器 (Shift+Ctrl+X) 讓你能夠在不使用內部的編輯器情形下改變文件絕大部分的外觀。而且 Inkscape 支援的 SVG 特性通常比圖形介面上可使用的還多。舉例來說,我們現在支援顯示遮罩和裁剪路徑,雖然沒有圖形介面可建立或修改。XML 編輯器是使用這些功能的唯一方法 (如果你了解 SVG 的話)。

改變尺標的測量單位

在預設的範本裡,尺標使用的測量單位為 px (「SVG 使用的單位」,在 Inkscape 裡等於 0.8pt 或 1/90 英寸)。這也是左下角的顯示坐標上使用的單位和所有選單裡預先選擇的單位。(你可把滑鼠游標停留在尺標上方會看見單位使用的相關工具提示。) 若要改變單位,開啟 文件偏好設定 (Ctrl+Shift+D) 並改變在 頁面 分頁上的預設單位

圖章

想要快速建立許多物件的複本,就使用圖章功能。先拖動物件(或者縮放、旋轉物件),然後當按住滑鼠按鈕時按空白鍵。這會留下目前物件形狀的「圖案」。你可根據需求重複這個動作好幾次。

筆工具的技巧

使用筆 (貝茲曲線) 工具,你有下列幾種方式來結束目前的線條:

注意當路徑處於未完成狀態 (即路徑呈現綠色,目前的線段呈現紅色),這個路徑尚未以物件形態存在文件中。因此,可用 Esc (取消整個路徑) 或 Backspace (移除未完成路徑的最後線段) 來取消路徑,而不用復原

要加入新的子路徑到現有的路徑,選取路徑並按著 Shift 從任意一個點開始繪製。但是如果你只不過想接續現有的路徑,那麼不需要按著 Shift 鍵;僅需從選取路徑的結束錨點開始繪製。

輸入 Unicode 字元

當使用文字工具時,按 Ctrl+U 可在一般模式與 Unicode 模式之間作切換。在 Unicode 模式中,你輸入的字會以 4 個十六進位數字為一組變成一個單一的 Unicode 字元,因而允許你輸入各種符號 (只要你曉得它們的 Unicode 區分碼且字型能支援)。按 Enter 可完成 Unicode 輸入。例如,Ctrl+U 2 0 1 4 Enter 可插入一個 em-dash (—)。按 Esc 可不插入任何字元便離開 Unicode 模式。

使用格線繪製圖示

假設你想製作一個 24x24 像素的圖示。建立一幅寬高為 24x24 px 的畫布 (使用文件偏好設定) 並設定格線為 0.5 px (48x48 的格線數)。這時,如果你將填充物件對齊偶數格線,而邊框物件對齊到奇數格線加上 px 單位的邊框寬度就變成偶數,並於預設 90dpi (也就是 1 px 變成 1 點陣圖像素) 匯出,你會得到一個清晰的點陣圖像,而沒有不必要的平滑效果。

物件旋轉

當使用選取工具,在物件上點擊會看到縮放箭頭,然後在物件上再點擊一次會見到旋轉、位移的箭頭。如果點擊和拖曳四個角上的箭頭,物件會繞著中心點旋轉 (顯示為十字標誌)。如果你在做這個動作時按住 Shift,那麼會繞著對角作旋轉。你也能將旋轉中心拖到任何地方。

或者,你可以按鍵盤上的 [] (15 度) 或 Ctrl+[Ctrl+] (90 度)作旋轉。按著 Alt 並按 [] 鍵可作緩慢的像素大小旋轉。

下落式陰影

Inkscape 支援高斯模糊 SVG 濾鏡,所以你可以輕易地給物件加上模糊的下落式陰影。選取一個物件,用 Ctrl+D 再製,按 PgDown 把再製物件放到原始物件的下方,將再製物件放置到比原始物件下面一點及右邊一點的位置。現在開啟「填充和邊框」對話窗並將模糊值改為 5.0。就是這樣!

將文字放置在路徑上

要將文字沿著曲線放置,同時選取文字和路徑並從文字選單中選擇置於路徑。這串文字會從路徑起點開始。一般來說最好的方式是建立一個你想要填入的明確路徑,而不是把文字填入到其他繪圖元件 — 這會讓你更好控制且不會影響到你的繪畫。

選取原始物件

當你有置於路徑上的文字、連結偏移物件或仿製物件,這些物件的來源物件/路徑可能很難選取,因為可能正好在底下或設定為隱形和/或鎖定。神奇的 Shift+D 會幫助你;先選取文字、連結偏移物件或仿製物件,然後按 Shift+D 可將選取移動到對應的路徑、偏移來源或仿製原始物件。

恢復超出螢幕的視窗

當在不同的解析度或一些顯示模式的系統之間移動文件時,你會發現 Inkscape 已經儲存了視窗位置,程式會把視窗放置到超出螢幕的地方。直接將視窗最大化 (使用任務欄會把視窗帶回檢視區),儲存並重新載入。你可以藉由取消勾選整體選項變成儲存視窗空間 (Inkscape 偏好設定視窗分頁) 來避免這種問題。

透明、漸層和 PostScript 匯出

PostScript 或 EPS 格式不支援透明,因此如果你想要匯出成 PS/EPS 就不要使用透明。至於平面透明會覆蓋平面色彩的問題,很簡單就能解決:選取透明物件的其中一個;切換到滴管工具 (F7);確認滴管工具是使用「點取可見顏色不含透明度」模式;然後在同物件上點擊。這會點取可見顏色並指派回到物件,但這次不包含透明度。對全部其他透明物件重複上述的步驟。如果你的透明物件蓋住一些平面顏色範圍,你需要相對地將它打散成數個元件並對每個元件套用上述的步驟。

匯出漸層到 PS 或 EPS 對文字 (除非文字已轉成路徑) 或邊框沒有作用。同樣地,由於透明在匯出 PS 或 EPS 時會遺失,你無法使用如同從不透明藍色到透明藍色這類的漸層;變通方法是用從不透明藍色到 不透明背景顏色的漸層取代原本的漸層。