Follow us on:

Home

Inkscape tutorial: Basique

Ce didacticiel présente les opérations de base d'Inkscape. C'est un document réalisé avec Inkscape que vous pouvez afficher, éditer et éventuellement sauver.

Le didacticiel basique aborde la navigation sur le canevas, la gestion des documents, les bases des outils de formes, la transformation d'objets à l'aide du sélecteur, les techniques de sélection, le groupement, les remplissages et contours, l'alignement et la superposition. Pour d'autres sujets, consultez les autres didacticiels dans le menu d'aide.

Se déplacer sur le canevas

Il existe plusieurs façons de se déplacer sur le canevas. Vous pouvez essayer le raccourci Ctrl+flèche pour vous déplacer dans ce document (essayez donc dès maintenant de faire défiler ce document vers le bas). Vous pouvez aussi vous déplacer à l'aide du bouton milieu de la souris ou utiliser les barres de défilement (Ctrl+B permet de les afficher ou non). La molette de la souris permet les déplacements verticaux, et même horizontaux en combinaison avec la touche Maj.

Zoomer ou dézoomer

Le moyen le plus simple est d'utiliser les touches - et + (ou =). Vous pouvez aussi zoomer avec Ctrl+clic-milieu ou Ctrl+clic-droit, et dézoomer avec Maj+clic-milieu ou Maj+clic-droit, ou bien utiliser la molette de la souris en tout en appuyant sur Ctrl. Vous pouvez aussi cliquer sur le champ de saisie (dans le coin en bas à droite de la fenêtre), y entrer une valeur de zoom, et la valider en pressant la touche entrée. Enfin, il reste l'outil de zoom (dans la barre d'outils à gauche) qui vous permet de définir une région sur laquelle zoomer à l'aide de la souris.

Inkscape garde aussi en mémoire un historique des niveaux de zoom. Appuyez sur les touches ` pour y naviguer en avant et Maj+` en arrière.

Les outils d'Inkscape

La barre d'outils verticale à gauche affiche les outils de dessin et d'édition d'Inkscape. En haut de la fenêtre, sous les menus, la barre de commandes affiche les boutons des commandes générales tandis que la barre de contrôle des outils montre les contrôles spécifiques à chaque outil.La barre d'état en bas de la fenêtre affiche des indications et des messages utiles lors de votre session.

Beaucoup d'autres opérations sont disponibles via les raccourcis clavier. Pour consulter tous les raccourcis disponibles, ouvrez le menu Aide > Clavier et souris.

Créer et gérer des documents

Pour créer un nouveau document vide, utilisez Fichier > Nouveau ou appuyez sur Ctrl+N. Pour ouvrir un fichier SVG existant, utilisez Fichier > Ouvrir (Ctrl+O). Utilisez Fichier > Enregistrer (Ctrl+S) pour sauver ou Enregistrer sous (Maj+Ctrl+S) pour sauver sous un nouveau nom (Inkscape est encore en développement, n'oubliez pas d'enregistrer votre travail fréquemment !).

Inkscape utilise le format SVG (Scalable Vector Graphics) pour ses fichiers. Le format SVG est un standard ouvert largement utilisé par les logiciels de graphisme. Les fichiers SVG sont basés sur le format XML et peuvent être édités à l'aide de n'importe quel éditeur de texte ou XML (ou avec Inkscape, bien sûr). Inkscape peut aussi importer ou exporter plusieurs autres autres formats (EPS, PNG).

Inkscape ouvre une nouvelle fenêtre pour chaque document. Naviguez entre elles avec votre gestionnaire de fenêtre (avec le raccourci Alt+Tab par exemple), ou utilisez le raccourci Ctrl+Tab, qui permet de circuler parmi les documents ouverts (créez dès maintenant un nouveau document et passez de celui-ci à ce document en guise d'exercice). Note : Inkscape traite ces fenêtres comme les onglets dans un navigateur web, ce qui signifie que le raccourci Ctrl+Tab ne fonctionne qu'avec des documents s'exécutant dans la même instance. Si vous ouvrez plusieurs fichiers depuis un navigateur de fichiers ou exécutez plusieurs instances d'Inkscape, cela ne fonctionnera pas.

Créer des formes

Il est temps de passer aux formes! Cliquez sur l'outil Rectangle dans la barre d'outils (ou appuyez sur F4) et avec un cliquer-déplacer, créez un rectangle, soit dans un nouveau document vide, soit dans celui-ci :

An example image

Comme vous pouvez le voir, par défaut, les rectangles sont bleus, complètement opaques et avec une épaisseur de contour de 1 pt. Nous allons bientôt voir comment changer cela. Avec les autres outils, vous pouvez aussi créer des ellipses, des étoiles et des spirales :

An example image

Ces outils sont les outils de formes. Chaque forme créée affiche une ou plusieurs poignées en forme de diamant; essayez de les déplacer pour voir comment la forme réagit. Pour chacun des outils de formes, la barre de contrôle fournit une façon supplémentaire de modifier la forme; ces contrôles affectent la forme sélectionnée (c'est à dire celle qui a ses poignées affichées) et définissent les paramètres par défaut qui s'appliqueront lors de la création de toute nouvelle forme.

Pour annuler votre dernière action, appuyez sur Ctrl+Z (ou si vous changez d'avis, vous pouvez refaire l'action annulée avec Maj+Ctrl+Z).

Déplacer, redimensionner et tourner

L'outil d'Inkscape le plus utilisé est le sélecteur. Cliquez sur le bouton tout en haut (celui avec la flèche) dans la barre d'outils (ou appuyez sur F1 ou sur la barre d'espace). Vous pouvez alors sélectionner n'importe quel objet sur le canevas. Exemple : cliquez sur le rectangle ci-dessous.

An example image

Vous devez voir apparaître huit poignées en forme de flèche autour des bords de l'objet. Vous pouvez maintenant :

Cliquez à nouveau sur le rectangle. Les poignées changent de forme. Vous pouvez maintenant :

Toujours avec le sélecteur, dans les champs numériques de la barre supérieure, vous pouvez définir précisément les coordonnées (X et Y) et la taille (L et H) de la sélection.

Transformer à l'aide des raccourcis clavier

Une des capacités d'Inkscape le distinguant d'autres éditeurs vectoriels est la possibilité d'utiliser le clavier de façon intensive. Il n'y a pratiquement pas d'action ou de commande qui ne soit pas accessible depuis le clavier, et la transformation d'objet ne fait pas exception.

Vous pouvez utiliser le clavier pour déplacer (flèches), redimensionner (< et >) et tourner ([ et ]) les objets. L'incrément par défaut de modification des dimensions et de déplacement est de 2 px; avec la touche Maj, le déplacement est multiplié par 10. Ctrl+> et Ctrl+< redimensionnent respectivement de 200% et 50% par rapport à l'original. L'incrément de rotation par défaut est de 15 degrés; ou de 90 degrés si vous appuyez sur simultanément sur Ctrl.

Mais les transformations à l'échelle du pixel sont peut-être les plus utiles, obtenues par la combinaison de la touche Alt avec un raccourci. Par exemple, Alt+flèche déplace la sélection d'1 pixel, au zoom courant (c'est à dire d'un pixel sur l'écran, à ne pas confondre avec l'unité px qui est une unité SVG de longueur indépendante du zoom). Ceci implique que si vous zoomez plus, un raccourci Alt+flèche provoquera un mouvement absolu plus petit, correspondant toujours à un pixel à l'écran. Il est ainsi possible de positionner des objets avec une précision arbitraire simplement en zoomant ou dézoommant selon les besoins.

De même, Alt+> et Alt+< changent les dimensions de la sélection d'1 pixel à l'écran, et Alt+[ et Alt+] la tournent de telle façon que le point le plus éloigné du centre bouge d'un seul pixel à l'écran.

Note : Les utilisateurs de Linux pourraient ne pas obtenir les resultats attendus avec Alt+flèche·et quelques autres combinaisons si leur gestionnaire de fenêtre récupere les évènements des touches avant qu'elles n'atteignent l'application Inksape. Une des solutions consiste à changer la·configuration du gestionnaire de fenêtres pour éviter cela.

Sélections multiples

Avec Maj+cliquer, vous pouvez simultanément sélectionner plusieurs objets. Avec un cliquer-déplacerVous pouvez aussi définir une zone autour des objets; on appelle ceci une sélection par bande étirable (le sélecteur crée une bande étirable quand on commence un cliquer-déplacer sur une zone vide; mais si vous appuyez sur Maj avant de cliquer, Inkscape forcera la création d'une bande étirable). Entraînez vous avec les trois formes ci-dessous :

An example image

Maintenant, utilisez la bande étirable (déplacer ou Maj+déplacer) à titre d'exemple pour sélectionner les deux ellipses mais pas le rectangle :

An example image

Tout objet sélectionné affiche une marque de sélection — par défaut une boîte l'entourant en pointillés. Ceci permet de distinguer facilement ce qui est sélectionné de ce qui ne l'est pas. Si, par exemple, vous sélectionnez les deux ellipses et le rectangle ci-dessus, sans ces indications, il vous sera difficile de savoir si les ellipses sont bien sélectionnées ou non.

Maj+cliquer sur un objet sélectionné l'exclut de la sélection. Sélectionnez les trois objets ci-dessus, puis utilisez Maj+cliquer pour exclure les deux ellipses de la sélection, en n'y conservant que le rectangle.

Appuyer sur Esc désélectionne tous les objets sélectionnés. Ctrl+A sélectionne tous les objets du calque courant (si vous n'avez pas créé de calque, vous sélectionnerez tous les objets du document).

Grouper

Plusieurs objets peuvent être réunis dans un groupe. Un groupe se comporte comme un simple objet quand vous le déplacez ou le transformez. Ci-dessous, les trois objets de gauche sont indépendants; les trois mêmes objets de doite sont groupés. Essayez de les déplacer.

An example image

Pour créer un groupe, sélectionnez un ou plusieurs objets et appuyez sur Ctrl+G. Pour dégrouper un ou plusieurs groupes, sélectionnez-les et appuyez sur Ctrl+U. Les groupes peuvent eux-mêmes être groupés, comme n'importe quels autres objets; de tels groupes récursifs peuvent avoir une profondeur quelconque. Mais, Ctrl+U ne dégroupe que le dernier niveau de groupe de la sélection; vous devrez répéter Ctrl+U si vous voulez dégrouper complètement des groupes de groupes.

Cependant, vous n'avez pas nécessairement besoin de dégrouper pour éditer un objet au sein d'un groupe. Un simple Ctrl+cliquer sur cet objet permet de le sélectionner seul et de l'éditer, ou Maj+Ctrl+cliquer sur plusieurs objets (inclus ou non dans des groupes quelconques) pour une sélection multiple. Essayez de déplacer ou transformer sans les dégrouper les formes du groupe ci-dessus à droite, puis de les désélectionner, et resélectionnez le groupe normalement pour vérifier qu'elles sont toujours groupées.

Remplissage et contour

Beaucoup de fonctions d'Inkscape sont accessibles par des boîtes de dialogues. La façon la plus simple d'attribuer une couleur à un objet est d'ouvrir la boîte de dialogue Palettes du menu Objet, sélectionner un objet et cliquer sur une montre (couleur) pour le peindre (modifier sa couleur de remplissage).

La boîte de dialogue Remplissage et contour (Maj+Ctrl+F) est plus puissante. Sélectionnez la forme ci-dessous et ouvrez la boîte de dialogue Remplissage et contour.

An example image

Vous constatez que la boîte de dialogue a trois onglets : Remplissage, Contour et Style de contour. L'onglet Remplissage permet d'éditer le remplissage (l'intérieur) de(s) objet(s) sélectionné(s). L'utilisation des boutons juste sous l'onglet vous permet de choisir le type de remplissage, incluant sans remplissage (le bouton avec un X), couleur uniforme, ou encore dégradé linéaire ou radial. Pour la forme ci-dessus, le bouton couleur uniforme devrait être activé.

Plus bas, vous pouvez voir la collection de sélecteurs de couleur chacun dans un onglet : RVB, TSL, CMJN, et Roue. Le plus pratique est peut-être la roue, dans laquelle vous pouvez tourner un triangle pour choisir une teinte sur la roue, puis une nuance dans le triangle. Tous les sélecteurs de couleur comportent une réglette pour définir l'alpha (opacité) de(s) objet(s) sélectionné(s).

Quand vous sélectionnez un objet, la boîte de dialogue Remplissage et contour est mise à jour pour afficher ses remplissage et contour courants (quand plusieurs objets sont sélectionnés, elle affiche la moyenne de leurs couleurs). Jouez avec les exemples ci-dessous ou créez les votres :

An example image

En utilisant l'onglet Contour, vous pouvez enlever le contour d'un objet ou lui attribuer n'importe quelle couleur ou transparence :

An example image

Le dernier onglet, Style de contour, vous permet de définir la largeur et les autres paramètres du contour :

An example image

Enfin, vous pouvez utiliser des dégradés au lieu de couleurs uniformes pour les remplissages comme pour les contours :

An example image

Quand vous passez d'une couleur uniforme à un dégradé, le dégradé nouvellement créé utilise cette même couleur, allant d'opaque à transparente. Utilisez l'outil de Dégradé (Ctrl+F1) pour déplacer les poignées de dégradé — les poignées de contrôle connectées par des lignes qui définissent la direction et la longueur du dégradé. Quand l'une de ces poignées est sélectionnée (surlignée en bleu), la boîte de dialogue Remplissage et contour permet de définir la couleur liée à cette poignée à la place de la couleur de l'objet sélectionné.

Une autre façon pratique de changer la couleur d'un objet est d'utiliser l'outil Pipette (F7). Un simple cliquer n'importe où sur le dessin avec cet outil permet d'attribuer la couleur ainsi capturée au remplissage de l'objet sélectionné (Maj+cliquer l'attribuera à son contour).

Duplication, alignement, distribution

Une des opérations les plus courantes est la duplication d'un objet (Ctrl+D). Le dupliqué est placé juste au dessus de l'original et est sélectionné, vous permettant ainsi de le déplacer à la souris ou avec des raccourcis. Pour vous exercer, essayer de remplir la ligne avec des copies du carré noir ci-dessous :

An example image

Il y a des chances que vos copies du carré ne soient pas bien alignées. La boîte de dialogue Aligner et distribuer (Ctrl+Maj+A) devient alors utile. Sélectionnez tous les carrés (avec Maj+cliquer ou une bande étirable), ouvrez la boîte de dialogue et appuyez sur le bouton "Centrer selon l'axe horizontal", puis sur "Distribuer des distances horizontalement entre les objets" (consultez les indications affichées quand la souris passe au-dessus des boutons). Les objets sont maintenant alignés et distribués de façon équidistante. Voici d'autres exemples d'objets alignés et distribués :

An example image

Ordre-z (ou superposition)

Le terme ordre-z correspond à l'ordre d'empilement des objets sur un dessin, les objets du dessus masquant les autres. Les deux commandes du menu Objet, Monter au premier plan (Début) et Descendre à l'arrière plan (Fin), feront passer les objets sélectionnés tout au dessus ou tout au fond dans la superposition des objets du calque courant. Deux autres commandes, Monter (Page Précédente) et Descendre (Page Suivante), les déplaceront d'un cran seulement, c'est à dire juste au-delà d'un objet non sélectionné (seuls les objets chevauchant la sélection comptent; si rien ne chevauche la sélection, Monter et Descendre la déplacent tout au dessus ou tout au fond respectivement.

Exercez-vous à l'utilisation de ces commandes en inversant la superposition des objets ci-dessous, de telle sorte que l'ellipse la plus à gauche soit tout au-dessus et la plus à droite tout au fond :

An example image

Un raccourci de sélection très utile est la touche Tab. Si rien n'est sélectionné, il sélectionne l'objet le plus au fond; sinon, il sélectionne l'objet juste au-dessus de l'objet sélectionné dans l'ordre-z. Maj+Tab fait l'inverse, commençant par l'objet tout au-dessus en allant vers le fond. Comme les objets que vous créez sont ajoutés au-dessus de la superposition, appuyer sur Maj+Tab quand aucun objet n'est sélectionné vous permettra de retrouver facilement le dernier objet que vous avez créé. Essayez Tab et Maj+Tab sur les ellipses superposées ci-dessus.

Sélectionner en-dessous et déplacer

Que faire si l'objet dont vous avez besoin est caché derrière un autre objet ? Vous pouvez encore voir l'objet en dessous si celui du dessus est (partiellement) transparent, mais en cliquant dessus, vous sélectionnerez l'objet du dessus, pas celui dont vous avez besoin.

Pour cela, il faut utiliser Alt+cliquer. Alt+cliquer sélectionne d'abord l'objet du dessus, comme un cliquer normal; mais le Alt+cliquer suivant au même endroit sélectionne l'objet juste en-dessous; et ainsi de suite. Donc, plusieurs Alt+cliquer à la suite vous permettront de naviguer du dessus vers le fond à travers la superposition de différents objets sous le pointeur de la souris. Quand l'objet du fond est sélectionné, un Alt+cliquer de plus sélectionne de nouveau l'objet du dessus.

[Si vous utilisez Linux, vous pourriez éventuellement vous appercevroi que Alt+clique ne fonctionne pas correctement, mais déplace la fenêtre Inkscape en totalité. Il s'agit de vôtre gestionnaire de fenêtres qui resèrve Alt+clque pour une action différente. Pour corriger cela, il aut trouver l'option de configuration du comportement des fenêtres de votre gestionnaire de fenêtre, puis la desactiver ou bien lui associer la touche Meta (touche Windows), ainsi configuré, Inkscape et les autres applications pourront librement utiliser la touche Alt.]

D'accord, mais une fois l'objet recouvert sélectionné, qu'en faire ? Vous pouvez le transformer grâce aux raccourcis et déplacer ses poignées de sélection. Cependant, déplacer l'objet lui-même resélectionnera l'objet tout au dessus à nouveau (le cliquer-déplacer est conçu comme cela : d'abord sélectionner l'objet le plus haut juste sous le curseur puis déplacer la sélection). Pour demander à Inkscape de déplacer la sélection présente (éventuellement en-dessous d'autres objets) sans rien sélectionner d'autre, utilisez Alt+déplacer. Cela vous permettra de déplacer la sélection courante où que vous placiez la souris.

Essayez Alt+cliquer et Alt+déplacer sur les deux formes brunes sous le rectangle vert transparent :

An example image

Conclusion

Ceci conclut le didacticiel basique. Inkscape offre beaucoup d'autres fonctionnalités, mais les techniques décrites ci-dessus vous permettront déjà de créer des dessins simples mais utiles. Pour un usage plus avancé, consultez le didacticiel avancé dans Aide > Didacticiels.