Follow us on:

Home

Inkscape tutorial: 基本

這篇教學示範 Inkscape 的基本使用。本文是標準的 Inkscape 文件,所以你可以觀看、編輯、複製內容或儲存。

基本教學的內容涵蓋畫布瀏覽、管理文件、形狀工具基礎、選取技巧、用選取器改變物件、群組、設定填色和邊框、對齊和排列順序。到說明選單中看看其他教學有更多進階的主題。

平移畫布

有許多方式來平移 (捲動) 文件畫布。試著用鍵盤上的 Crtl+方向鍵 來捲動。(立刻嘗試這個方法向下捲動這個文件。) 你也可以用滑鼠中鍵拖動畫布。或者,使用捲軸 (按 Ctrl+B 以顯示或隱藏捲軸)。滑鼠滾輪 也可進行垂直方向的捲動;按 Shift 並滾動可水平捲動。

縮放畫面

-+ (或 =) 按鍵進行縮放是最簡單的方法。你也可以用 Ctrl+點擊滑鼠中鍵 或者 Ctrl+點擊滑鼠右鍵 來放大畫面、Shift+點擊滑鼠中鍵Shift+點擊滑鼠右鍵 來縮小畫面,或按著 Ctrl 滾動滑鼠滾輪。或者,你可以在縮放輸入區中點擊一下 (在文件視窗的左下角),輸入一個縮放畫面的精確值 (單位為 %),並按一下 Enter 鍵。我們也有縮放工具 (在左側的工具列中) 讓你經由拖動周圍放大到一個區域。

Inkscape 也保留在這個工作階段中使用過的縮放層級記錄。按下 ` 鍵回到上一個縮放狀態,或 Shift+` 前往下一個。

Inkscape 工具

於左側的垂直工具列陳列著 Inkscape 的繪製和編輯工具。在視窗頂端、選單的下面,有包括一般命令按鈕的命令列和每個工具特性控制的工具控制列。位於視窗底部的狀態列在你使用時會顯示有用的提示和訊息。

許多操作可由鍵盤的快捷鍵達成。開啟 說明 > 鍵盤和滑鼠 可看見完整的參照。

建立和管理文件

可使用 檔案 > 新增 或按 Ctrl+N 建立一個新的空白文件。使用 檔案 > 開啟 (Ctrl+O) 開啟一個現有的 SVG 文件。使用 檔案 > 儲存 (Ctrl+S) 進行儲存,或用 另存為 (Shift+Ctrl+S) 根據新的檔名來儲存。(Inkscape 仍可能不穩定,所以記得時常儲存!)

Inkscape 使用 SVG (可縮放向量圖形) 格式作為檔案格式。SVG 是一個開放的標準,被圖形軟體廣泛地支援。SVG 檔案基於 XML 並且可藉由任何的文字或 XML 編輯器進行編輯 (Inkscape 以外的軟體)。除了 SVG 外,Inkscape 可以匯入和匯出幾種其他格式 (EPS、PNG)。

Inkscape 對每一個文件開啟一個分離視窗。你可以使用你的視窗管理程式 (例如用 Alt+Tab) 在它們之間瀏覽,或者使用 Inkscape 快捷鍵 Ctrl+Tab 循環切換所有開啟的文件視窗。(現在建立一個新文件,並在新文件和本文件之間切換進行練習。) 注意:Inkscape 將這些視窗視為像網頁瀏覽器中的分頁一樣,這表示 Ctrl+Tab 快捷鍵只對在同一程序的文件有用。如果你從檔案瀏覽器中開啟多個檔案或從圖示啟動數個 Inkscape 程序,那麼快捷鍵就不會有作用。

建立形狀

學習製作一些漂亮的形狀!點擊在工具列上的矩形工具 (或按 F4) 然後在一個新的空白文件或這裡點擊並拖曳:

An example image

如你所見,預設矩形為藍色,帶有黑色 邊框 (輪廓),而且完全不透明。下面內容我們將會見到如何去改變它。用其他工具,你也可以建立橢圓形、星形和螺旋形:

An example image

這些工具統稱為形狀工具。每個你建立的形狀會顯示一個或多個方塊形狀的控制點;試著拖動它們可見到形狀如何跟著變化。形狀工具的控制面板可用另一種方式來微調形狀;這些控制影響目前選擇的形狀 (即那些顯示的控制點) 並且將會套用到新建立形狀的預設情形。

Ctrl+Z復原你上一個動作。(或者,如果你改變主意,可以用 Shift+Ctrl+Z 重做復原的動作。)

移動、縮放、旋轉

使用最頻繁的 Inkscape 工具就是選取器。點選工具列上最上面的按鈕 (箭頭),或者按 F1空白鍵。現在你可以在畫布上選取任何物件。點擊下面的矩形。

An example image

你會見到 8 個箭頭形狀的控制點出現在物件的四周。現在你可以:

現在再點一次矩形。控制點改變了。現在你可以:

當用選取器時,你也可以使用控制列上的數字輸入區來設定選取的坐標 (X 和 Y) 和大小 (寬和長) 的準確數值。

用按鍵改變物件

一個 Inkscape 的特色是除了大部份向量繪圖的特點以外還強調能用鍵盤完成所有設定。幾乎沒有任何命令和動作是鍵盤做不到的,改變物件也沒有例外。

你可以使用鍵盤來移動 (方向鍵)、縮放 (<> 鍵) 和旋轉 ([] 鍵) 物件。預設移動和縮放的單位為 2 px;按 Shift,以 10 倍預設值來移動或縮放。Ctrl+>Ctrl+< 分別放大或縮小為原來的 200% 或 50%。預設以 15 度作旋轉;按 Ctrl,可以 90 度作旋轉。

無論如何,或許最有用的是像素大小的改變,藉由使用 Alt 搭配改變按鍵來調用。例如,Alt+方向鍵在目前的畫面中以 1 像素移動選取物件 (即 1 螢幕像素,不要和 SVG 的長度單位 px 混淆了)。這表示如果你放大畫面,Alt+方向鍵 執行一次得到的結果是較小的絕對移動量,在你的螢幕上仍然看起來像是 1 像素輕輕移動。因此需要時可能由畫面縮放簡單、準確地把物件放置到任意位置。

同樣地,Alt+>Alt+< 縮放選取物件是可見大小改變 1 螢幕像素,而 Alt+[Alt+] 旋轉是以距中心最遠的點移動 1 螢幕像素。

注意:如果 Linux 使用者的視窗管理程式在進行 inkscape 應用前捕獲那些按鍵事件,那麼可能無法得到 Alt+方向鍵 和一些其他按鍵組合預期的結果。因此其中一個解決辦法就是改變視窗管理器的設置。

多重選取

你可以用 Shift+多次點擊 來同時選取任意數目的物件。或者,你可以在需要選取的物件周圍拖曳;這稱為框選。(當從一個空白區域拖曳時,選取器會產生一個矩形線框;不過如果你在開始拖曳前按 Shift,Inkscape 就會一直產生矩形線框。)藉由選取下面全部三個物件做練習:

An example image

現在,使用框選 (拖曳或 Shift+拖曳) 來選擇這兩個橢圓,但不要矩形:

An example image

每個單獨的物件在選取範圍內會顯示選取標示 — 預設是一個矩形虛線框。這些標示使得容易一眼看出哪個被選取、哪個沒被選取。舉例來說,如果你選擇兩個橢圓形和一個矩形,沒有標示的情況下你會很難猜測橢圓形是否已被選取。

在一個已選取的物件上按 Shift+點擊 可從選取區中將它排除。選取上面全部三個物件,然後使用 Shift+點擊 從選取區中將兩個橢圓形排除只留下矩形。

Esc 鍵可取消選取任何已選擇的物件。Ctrl+A 可選取再目前圖層中所有的物件(如果你沒有建立圖層,那就變為選取文件中的所有物件)。

群組

幾個物件可結合為一個群組。一個群組於拖曳或變形時會表現得像單一個物件。下面左邊的三個物件是獨立的,而右邊相同的三個物件是已群組的。試著拖動這個群組看看。

An example image

你選取一個或多個物件並按 Ctrl+G 可建立一個群組。選取它們並按 Ctrl+U 可解散一個或多個群組。多個群組本身可能被群組,只是看起來像任何其他物件;這樣遞迴的群組可以做下去到任意深度。然而,Ctrl+U 只會解散一個選取中最上層的群組;如果想要完全解散深層的「群組中有群組」,那麼就需要重複地按 Ctrl+U

如果想要編輯群組中的一個物件,你未必一定得解散群組。只要 Ctrl+點擊 那個物件,那麼物件會被選取並可被編輯,或者 Shift+Ctrl+點擊 多個物件(任何群組的內部或外面)來多重選取而不管群組與否。試著以不解群組散的情形下移動或改變群組中個別的形狀,然後做一般的取消選取和選取此群組會見到它仍然保持群組狀態。

填色和邊框

Inkscape 的許多功能可經由對話窗使用。讓物件塗上一些顏色最簡單的方式大概是從檢視選單中開啟色票對話窗 (或按 Shift+Ctrl+W),選取一個物件並點擊一個色票來塗上顏色 (改變它的填色)。

更強大的是從物件選單中開啟的填充和邊框對話窗 (或按 Shift+Ctrl+F)。選取下面的形狀並開啟填充和邊框對話窗。

An example image

你會見到對話窗有三個分頁:填充、邊框顏色和邊框樣式。填充分頁讓你編輯選取物件的填色 (內部)。使用於分頁下面一點的按鈕可選擇填入類型,包括沒有填色 (有 X 圖案的按鈕)、純色填充、線性漸層或放射狀漸層。以上面的形狀來說,純色填充按鈕會是開啟的狀態。

更進一步你會看到顏色選擇器的集合在它們自己所屬的分頁中:RGB、CMYK、HSL和色環。色環選擇器大概是最方便的,你可以旋轉三角形來選擇色環上的色相,然後在三角形範圍裡選擇那個色相的明暗程度。所有顏色選擇器包含一個滑動拉桿可設定選取物件的 alpha 值(不透明度)。

每當你選擇一個物件,顏色選擇器會更新並顯示目前的填色和邊框 (若是多重選取,對話窗顯示是它們的平均顏色)。用這些樣品玩玩或建立你自己的:

An example image

使用邊框填塗分頁可以移除物件的邊框 (輪廓),或者指定任何顏色或透明度 :

An example image

最後一個分頁「邊框樣式」讓你設定寬度和邊框的其他參數:

An example image

最後,你可以用漸層色替代純色作為填色和(或)邊框顏色:

An example image

當你從純色切換為漸層時,會使用先前的純色建立新的漸層 (從不透明到透明)。切換到漸層工具(Ctrl+F1)可拖動漸層控制點 — 連接控制點的直線定義漸層的方向和長度。當任何漸層控制點被選取時 (以藍色標示),填色和邊框對話窗變為控制點的顏色而非選取物件整體的顏色。

還有另一種簡便的方式可改變物件的顏色就是使用滴管工具 (F7)。只要用這個工具點擊一下繪圖區中的任何地方,那麼點取的顏色會被指定為選取物件的填色 (Shift+點擊 會指定邊框顏色)。

再製、對齊、分佈

最常見的動作之一為再製物件 (Ctrl+D)。再製物件會放置在原本物件的正上方並且已選取,所以你可以用滑鼠或方向鍵將它拖走。試著用這個黑色正方形排成直線作為練習:

An example image

有可能你的正方形複製品或多或少被任意擺放。這時對齊對話窗 (Ctrl+Shift+A) 就相當有用。選取所有正方形(Shift+點擊或拖曳一個選框),開啟對話窗並點選「水平置中」按鈕,然後點選「物件間以同樣的水平間距來分佈」按鈕(閱讀按鈕的工具提示)。這些物件現在排列整齊且等距離分佈。這裡是一些其他對齊和分佈的例子:

An example image

排列順序

排列順序這項涉及繪畫時物件的堆疊次序,即哪些物件在頂層而遮住其他物件。在物件選單中有兩個指令 — 提到最上層 (Home 鍵) 和降到最下層 (End 鍵),可移動你的選取物件到目前圖層排列順序的最上層和最下層。另外兩個指令 — 提升 (PgUp) 和降低 (PgDn),可只作一次下沉或上升選取,即在排列順序中移動它越過一個非選取物件(只有物件重疊選取區時才算;如果沒有東西重疊選取區,提升和降低會移到相應的最上層和最下層)。

以反向順序排列下面的物件來練習這些指令,所以最左邊的橢圓形在頂層而最右邊那個在底層:

An example image

Tab 鍵是非常有用的選取快捷鍵。如果沒有任何選取,那麼它會選取最下層的物件;不然它會選取排列順序中選取物件上面的一個物件。Shift+Tab 則反之,從最上層物件開始且向下進行。你建立的物件新增至堆疊的最上層,於沒有任何選取情形下按下 Shift+Tab 可簡便地選取你最後建立的物件。於上面堆疊在一起的橢圓形上練習 TabShift+Tab 鍵。

選取下方物件和拖曳選取物件

如果你需要的物件隱藏在其他物件背後,該怎麼辦?如果上層物件 (可能) 是透明的,你仍然可看見底層的物件,但是在它上面點擊會選取到上層的物件 (你不需要的那個)。

Alt+點擊 就是針對這種情況。首先用 Alt+點擊 選取上層的物件就像普通的點選。然而,再次 Alt+點擊 同一個點會選取上層物件下面的那個物件;再做一次會選取更下面的物件,等等。因此,連續 Alt+點擊 幾次會從上層到下層循環,經由點擊位置上的物件群整個堆疊順序。當達到最下層物件時,再 Alt+點擊 一次自然會再一次選取最上層物件。

[如果你在 Linux 下,你會發現 Alt+點擊 可能沒有作用。相反地,可能會變成拖動整個 Inkscape 視窗。這是因為你的視窗管理程式已經預定 Alt+點擊 為不同的動作。修正這個問題方法為找到視窗管理程式的視窗行為配置並關閉它,或者將它對應到使用 Meta 鍵 (亦稱 Windows 鍵),如此一來 Inkscape 和其他應用程式便可自由使用 Alt 鍵。]

這樣不錯,但是你選取一個表面下的物件可以做些什麼?可以用按鍵改變它和拖曳選取控制點。然而拖動物件本身會再次變回選取最上層物件(這是點擊和拖曳設計為如何工作 — 它會先選取游標下的(最上層)物件,然後拖曳選取)。使用 Alt+拖曳 來告訴 Inkscape 現在什麼被選取要進行拖動而不要選取任何別的東西。這將會移動目前的選取而不管你的滑鼠拖曳到哪裡。

在綠色透明矩形下面的兩個褐色形狀上練習 Alt+點擊Alt+拖曳

An example image

結論

對基本教學作一個總結。Inkscape 遠不止這些,但經由這裡介紹的技巧,你已經可以製作簡單而有用的圖形。閱讀 說明 > 指導手冊 中的進階和其他教學了解更複雜的東西。