Follow us on:

Home

Inkscape tutorial:

Questo tutorial dimostrerà vari trucchi che gli utenti hanno imparato nell'uso di Inkscape e qualche caratteristica "nascosta" che può aiutarti a velocizzare la produzione.

Piazzamento radiale mediante "Cloni in serie"

E' facile capire come usare la finestra di dialogo Cloni in serie per le griglie e motivi rettangolari. Ma se hai bisogno di un piazzamento radiale, dove gli oggetti hanno un centro di rotazione comune? Anche questo è possibile!

Se il tuo motivo radiale deve avere solo 3,4,6,8 o 12 elementi, puoi provare con le simmetrie P3, P31M, P3M1, P4, P4M, P6, o P6M. Queste funzionano bene per i fiocchi di neve e simili. Un metodo più generale, comunque, è il seguente.

Scegli la simmetria P1 (traslazione semplice) e allora compensa questa traslazione andando nella scheda Spostamento e impostando a -100% lo spostamento Y per riga e lo spostamento X per colonna. Ora tutti i cloni saranno disposti esattamente sopra l'originale. Tutto ciò che riamane da fare e andare nella scheda Rotazione e impostare un angolo di rotazione per colonna, quindi crea il motivo con una riga e colonne multiple. Per esempio, qui c'è un motivo realizzato con linee orizzontali, con 30 colonne, ognuna ruotata di 6 gradi:

An example image

Per avere un quadrante di orologio partendo da questo, tutto ciò che devi fare è togliere o semplicemente sovrapporre la parte centrale con un cerchio bianco (per fare operazioni booleane sui cloni, scollegali prima).

Effetti più interessanti possono essere creati usando sia le righe che le colonne. Qui c'è un motivo con 10 colonne e 8 righe, con rotazione di 2 gradi per riga e 18 per colonna. Ogni gruppo di linee qui è una "colonna", cosi i gruppi sono a 18 gradi l'uno dall'altro; all'interno di ogni colonna, le singole linee sono separate da 2 gradi:

An example image

Negli esempi di sopra, la linea è stata ruotata attorno al suo centro. Ma se vuoi il centro fuori dal tuo oggetto? Crea un rettangolo invisibile (nessun riempimento ne contorno) che dovrebbe coprire il tuo oggetto e il cui centro è il punto di cui hai bisogno, raggruppa l'oggetto con il rettangolo, e usa Cloni in serie su questo gruppo. In questo modo puoi produrre "esplosioni" o "getti" rendendo casuale la scala, la rotazione, e l'opacità:

An example image

How to do slicing (multiple rectangular export areas)?

Create a new layer, in that layer create invisible rectangles covering parts of your image. Make sure your document uses the px unit (default), turn on grid and snap the rects to the grid so that each one spans a whole number of px units. Assign meaningful ids to the rects, and export each one to its own file (File > Export Bitmap (Shift+Ctrl+E)). Then the rects will remember their export filenames. After that, it's very easy to re-export some of the rects: switch to the export layer, use Tab to select the one you need (or use Find by id), and click Export in the dialog. Or, you can write a shell script or batch file to export all of your areas, with a command like:

inkscape -i area-id -t filename.svg

per ogni area da esportare. L'opzione -t dice di usare il nome del file scelto in precedenza, altrimenti puoi fornire un altro nome mediante l'opzione -e. In alternativa, puoi usare il programma svgslice per esportare automaticamente dai documenti SVG Inkscape, usando o un livello di ritaglio o le guide.

Gradienti non-lineari

La versione 1.1 di SVG non supporta i gradienti non-lineari (cioè quelli che hanno una transizione non-lineare tra i colori). Puoi comunque emularli mediante i gradienti multistop.

Iniziamo con un semplice gradiente a due stop. Apri l'editor dei Gradienti (facendo doppio click su una qualunque maniglia con lo strumento Gradiente). Aggiungi un nuovo passaggio (stop) nel mezzo; spostalo un po'. Allora aggiungi più passaggi prima e dopo il passaggio di mezzo e spostali, in modo che il gradiente risulti liscio. Più stop aggiungi, più liscio puoi rendere il tuo gradiente. Qui trovi il gradiente iniziale bianco-nero con due passaggi:

An example image

E qui trovi vari gradienti non-lineari con multistop (analizzali mediante l'editor dei Gradienti):

An example image

Gradienti radiali eccentrici

I gradienti radiali non devono essere necessariamente simmetrici. Con lo strumento Gradiente, sposta con Maiusc la maniglia centrale di un gradiente ellittico. Questo sposterà la maniglia a forma di X del fuoco lontana dal suo centro. Quando non ne hai bisogno, puoi spostare il fuoco nuovamente al centro.

An example image

Allineamento al centro della pagina

To align something to the center or side of a page, select the object or group and then choose Page from the Relative to: list in the Align and Distribute dialog (Ctrl+Shift+A).

Pulizia del documento

Molti gradienti, motivi e delimitatori non più usati (più precisamente quelli che hai modificato manualmente) rimangono nelle corrispondenti tavolozze e possono essere riutilizzati per nuovi oggetti. Comunque se vuoi ottimizzare il tuo documento, usa il comando Definizioni superflue nel menù File. Eliminerai tutti i gradienti, i motivi, o i delimitatori che non vengono usati all'interno del documento, rendendo il file più piccolo.

Proprietà nascoste e l'editor XML

The XML editor (Shift+Ctrl+X) allows you to change almost all aspects of the document without using an external text editor. Also, Inkscape usually supports more SVG features than are accessible from the GUI. The XML editor is one way to get access to these features (if you know SVG).

Cambiare le unità di misura del righello

Nel modello di preimpostato, l'unità di misura impostata per il righello è il px (pixel, "unità utente SVG", in Inkscape equivale a 0.8pt o a 1/90 di pollice). Questa è anche l'unità usata nel mostrare le coordinate nell'angolo in basso a destra ed è preselezionata in tutti i menù di misure. (Puoi sempre spostare il puntatore sul righello e vedrai un tooltip mostrare l'unità di misura usata). Per cambiare l'unità di misura, apri Proprietà Documento(Ctrl+Maiusc+D) e cambia Unità Predefinita nella scheda Pagina.

Duplicazione veloce

Per creare molte copie di un oggetto in maniera rapida, prendilo e mentre tieni premuto il pulsante del mouse calca Spazio. Lascerai una sorta di timbro dove e quante volte vorrai.

Trucchi con lo strumento Penna

Con lo strumento Penna, hai le seguenti opzioni per terminare la tua linea:

Nota che quando il tracciato non è finito (ovvero esso è verde, con l'ultimo segmento in rosso) esso non esiste ancora come oggetto del documento. Perciò, per cancellarlo, usa o Esc (cancella l'intero tracciato) o Backspace (rimuove l'ultimo segmento non concluso) al posto di Annulla nel menù Modifica.

Per aggiungere un nuovo sottotracciato ad un tracciato esistente, seleziona il tracciato e inizia a disegnare premendo Maiusc da un punto arbitrario. Se, comunque, vuoi semplicemente continuare un tracciato esistente, non è necessario premere Maiusc; inizia il disegno da uno dei due punti di ancoraggio del tracciato selezionato.

Inserire valori Unicode

While in the Text tool, pressing Ctrl+U toggles between Unicode and normal mode. In Unicode mode, each group of 4 hexadecimal digits you type becomes a single Unicode character, thus allowing you to enter arbitrary symbols (as long as you know their Unicode codepoints and the font supports them). To finish the Unicode input, press Enter. For example, Ctrl+U 2 0 1 4 Enter inserts an em-dash (—). To quit the Unicode mode without inserting anything press Esc.

Uso della griglia per disegnare icone

Mettiamo che tu voglia creare una icona 24x24. Crea una pagina di 24x24 px (usa Proprietà Documento) e imposta la griglia a 0.5 px (griglia 48x48). Ora, se tu allinei gli oggetti riempiti alle linee griglia pari, e gli oggetti con contorno a quelle dispari con un contorno di spessore un numero di px pari, e lo esporti con una risoluzione di 90dpi (cosi che 1px diventa 1 pixel bitmap), otterrai un immagine bitmap precisa senza anti-aliasing superfluo.

Rotazione di oggetti

Con lo strumento Selezione, clicca su un oggetto per mostrare le frecce di ridimensionamento, allora clicca di nuovo sull'oggetto per mostrare quelle di rotazione e slittamento. Se le frecce agli angoli vengono cliccate e spostate, l'oggetto ruoterà attorno al centro (mostrato con un segno a croce). Se premi anche lo Maiusc mentre fai ciò, la rotazione avverrà attorno all'angolo opposto. Puoi anche spostare il punto di rotazione ovunque.

Oppure, puoi ruotare mediante la tastiera premendo [ and ] (di 15 gradi) o Ctrl+[ and Ctrl+] (di 90 gradi). Sempre mediante [] ma con il tasto Alt ruoterà di un pixel.

Ombre

Inkscape supporta il filtro SVG della sfocatura Gaussiana, con il quale puoi facilmente creare ombre sfocate dietro i tuoi oggetti. Seleziona un oggetto, duplicalo mediante Ctrl+D, premi PgDown per metterlo dietro l'oggetto originale, posizionalo un po più in basso e un po' più in alto rispetto all'originale. Ora apri la finestra di dialogo Riempimento e Contorno e cambia il valore della Sfocatura al valore di 5.0. Fatto!

Posizionare un testo su un tracciato

Per posizionare un testo su un tracciato, seleziona un testo e il tracciato insieme e scegli Metti su tracciato dal menù Testo. Il testo inizierà all'inizio del tracciato. In generale è meglio creare un apposito tracciato che sia adatto al testo, piuttosto che adattare del testo ad un disegno esistente - questo ti darà maggior controllo senza distorcere i tuoi disegni.

Selezionare l'originale

Quando hai un testo su un tracciato, una proiezione collegata, o un clone, il loro oggetto/tracciato sorgente può essere difficile da selezionare perchè esso è esattamente sottostante o reso invisibile e/o bloccato. Il tasto magico Maiusc+D ti aiuterà; seleziona il testo, la proiezione collegata, o il clone e premi Maiusc+D per muovere la selezione verso il corrispondente tracciato, la sorgente della proiezione o il clone originale.

Recupero di finestre fuori dallo schermo

Quando muovi documenti tra sistemi con differenti risoluzioni o numero di schermi, può capitare che Inkscape salvi la posizione di una finestra che posiziona la finestra fuori dal tuo schermo. Semplicemente massimizza la finestra (che tornerà ad essere visibile, usa la barra delle applicazioni), salva e ricarica. Puoi negare questo una volta per tutte deselezionando l'opzione globale di salvare la geometria della finestra (Preferenze Inkscape, scheda Finestra).

Trasparenze, gradienti e esportare PostScript

I formati PostScript o EPS non supportano la trasparenza,quindi non dovrai mai usarla se hai intenzione di esportare in PS/EPS. Nel caso di trasparenza piatta che si sovrappone ad un colore piatto, è facile rimediare: seleziona un oggetto trasparente, seleziona lo strumento Contagocce (F7); assicurati che sia nella modalità "prendi colori senza alfa"; clicca sullo stesso oggetto. Prenderai cosi il colore visibile e lo assegnerai direttamente all'oggetto, ma questa volta senza trasparenza. Ripeti per tutti gli oggetti con trasparenza. Se il tuo oggetto trasparente ricopre parecchie aree di colore piatto, avrai bisogno di dividerlo in pezzi in corrispondenza delle aree e applicare questa procedura per ogni pezzo.

L'esportazione di gradienti in PS o EPS non funziona per il testo (a meno che il testo non sia convertito in tracciato) o per il contorno. Inoltre, visto che la trasparenza si perde nei PS o EPS esportati, non puoi usare ad esempio un gradiente da blu opaco a blu trasparente; come alternativa, sostituiscilo mediante un gradiente da blu opaco al colore opaco di sottofondo.